Notice VPN Issue Workaround

A) Yes I use Switch
B) From what I read here, you're saying the problem lies with Switch's implementation of IKEv2. Would this issue as you understand it persist with other protocols? (Ex, L2TP?) because I can't get those to work either.

Cheers!
The L2tTP protocol is slower and is usually cut by the Windows and Linux firewall natively. Since it is a tunnel at level layer 2. Both L2TP and IKv2 are slow and give a lot of lag and ping that can lead to believe that there is no internet connection for applications that need a quick response.
 
Unable, no control above the computer level. Yay University housing.
SwiithcVPN uses the UDP 500 port that is always closed by default, or you open and close it when you do not use SwithcVPN or create rules on your w10 firewall,so that it opens and closes ports for your SwitchVPN
 
1) Opened Windows Firewall UDP500.
2) Reinstalled SwitchVPN
3) Confirmed driver install and VPN works.
4) VPN Still not detected by the game. It seems isolated to Elite. VPN works on everything else.

I am pretty sure it's not a problem with the VPN but with Elite detecting the VPN.
 
Can confirm, NOT (that's a negative) fixed.

My VPN adapter does not show up in the logs or as a valid adapter.

So... yeah. Not 100% Fixed.
I use NordVPN and it works 100%. I submit that your VPN is not fully implementing a supported TAP protocol. Not an Fdev issue.
 
I'm moving through and trying to do my due diligence, but I've tried two more VPNs that have also not worked or been detected, Cactus VPN and ZPN connect, both VPNs have been able to connect, but none of them have been registered by Elite. (TAP verified working)

It's also worth noting that NORDVPN did not even connect.

I do know that it's entirely possible that it's my network Admins with whatever changes were made with the Net Code have blocked everything, but it would be certanly coincidental timing to be sure.
 
The new net-code has some weird behavior...

I don't use a VPN but I have multiple fixed IPs from different subnets set to my NIC for testing purposes (via the advanced TCP/IP settings dialog in the Windows IP4 protocol settings).
It seems, that the new ED net-code enumerates those IPs and uses the last IP from this list. But this IP was from a subnet that was not connected and so I was unable to connect to the server...
After removing this IP from my config I was able to connect to the ED server again!

I use this configuration since many years on my system and never had any issues with it with any software. ED also worked great until that update!
The net-code should check the default gateway and use an IP that lies in the same subnet as the default gateway IP - or let the OS handle the routing based on the correct metric (cmd> route print)...

cu
 
I'm not sure if I'm allowed to sound specific vpn services, but mine works just fine without any changes in config file.
 
Top Bottom