Notice VPN Issue Workaround

Will Flanagan

Community Manager
Frontier
To follow on from Howard, the correct string should be:

Code:
<Network Port="0"
upnpenabled="1"
LogFile="netLog"
PingTime="27"
MaxUpRate="250000"
DatestampLog="1"
SendCompressedIDs="0"
>
<UseNic>123.45.6.7</UseNic>
</Network>
We've updated the OP to reflect this as well.
 
It looks like there was an error in communication at some point - the correct XML for this setting is a child element, not an attribute, as follows:

<Network ... various attributes... >
<UseNic>123.45.6.7</UseNic>
</Network>

This is used when you have multiple network adapters (a VPN driver appears as an extra network adapter to the operating system) and the game for any reason does not pick the one you want it to use - with this setting, if there is a network adapter that has the specified IP address, the game will attempt to use that one.
Hello! Stil not working. I want to provide maximum info, probably it will help.
My ISP required vpn connection in order to access internet. Without that VPN connection only ISP official site is available. This is my VPN connection:
144605

Im not sure if Windows recognize this VPN connection as network adapter, because its established through default Windows interface and no additional ethernet adapters is simulated. Here is my network connections list and VPN connection Status->Details:
144609

This is Ethernet Details:
144611

My external IP, that I can found on sites like https://whatismyipaddress.com/ , is 95.27.xx.xx.
What I tried to add in AppConfig.xml:
144613
External IP, and all others IPs, that I found in ethernet and VPN details. But everytime I still cant connect to Frontier servers and there is only my local IP in ingame network options:
144615


Im not sure if it is important, but I found that in file AppNetCfg.xml (C:\Users\user_name\AppData\Local\Frontier Developments\Elite Dangerous) always shown my external IP and it is shown right.

Thanks =)
 
Hullo! Just reporting in new testing. Much like RReds I'll be providing as much information as possible. Provided fixes are not working.

144623

144624

144625

144627

144628

144629

144630

Network Log link: https://pastebin.com/jq0L4bBh
 
Hullo! Just reporting in new testing. Much like RReds I'll be providing as much information as possible. Provided fixes are not working.





Network Log link: https://pastebin.com/jq0L4bBh
The IPv4 addresses within your SwitchVPN App and SwitchVPN-IKEv2 Details are different. I see you configured the AppConfig using the IP from the former - what happens if you use the IP from the latter (i.e. 10.11.12.78)?
 
The IPv4 addresses within your SwitchVPN App and SwitchVPN-IKEv2 Details are different. I see you configured the AppConfig using the IP from the former - what happens if you use the IP from the latter (i.e. 10.11.12.78)?
Hunh. Never noticed that before. That's weird for sure. However testing, no difference.

144644

That's weird though, don't know why that's happening.
 
o7

I work in IT all day. Whenever I encounter Windows VPN issues, the first thing I try is the following:

1. File Explorer to C:\Users\USERNAME\AppData\Roaming\Microsoft\Network\Connections\Pbk\ (AppData is a hidden folder so unhide it)
2. Double click on the file rasphone.pbk
3. Select your VPN connection.
4. Click Properties then the Networking tab.
5. Uncheck TCP/IPv6. (most VPN providers don’t support the IPv6 protocol yet)
6. Click on TCP/IPv4 > Properties > Advanced
7. Note the status of "Use default gateway on remote network".
8. Check or uncheck it depending on what its set to and OK out of these dialogs.
9. Connect to your VPN and try to play Elite.
10. If it works then leave it alone. If it does not work, go back and restore the Gateway checkbox, and wait for FDev to fix the problem.

50/50 chance of success. Hope this helps.

X.

144744
 
Last edited:
An even better resource is a dev using their own property.

But bookmarked. Guess this is the best I can expect.

Man FD could learn a thing or 20 from ZOS.
Wait, are you implying that all 3rd tool party around the game should have been ED features ? Ouch, and to Stuart ? Double ouch.
 
Unfortunately didn't work for me, VPN provider makes virtual adapters as needed and cycles them cleanly every time it starts so I can't preset that kind of setting. Hope it works for others though!
Thanks for the feedback Rixxen. Yes, some providers are like this. Sorry it didn't help.
X.
 
This has just worked for me using VPN Unlimited. I switched the protocol from IKEv2 to OpenVPN, starting ED the game connected without any editing of the AppConfig file.
That's good news! That also does possibly point toward progress being made - if you can use OpenVPN (TCP/UDP) then that's good. Now all that remains are the other protocols (for those of us who can't use OpenVPN) :D
 
Defining correct NIC in Appconfig.xml solved the problem (thanks, Rixxan). Next step for devs is to implement option to bind NIC by NAME or IP to Elite Client.
 
Bears repeating that you can install your VPN on your router instead of your computer and then all these problems go away. If you are on the road a lot, get something like this:


IMO this is a better and safer solution anyway.
 
Top Bottom