Release Trade Computer Extension Mk.II

Eventure, I like the Summary Panel but use the old view.
I also have the plaing Elite Dangerous, not Horizons, as I have no desire to land at any planets at this time - like the original Elite from the 1980s!

Would it be possible for you to add an option switch to remove the display about Planetary Outposts for people like me?

Thanks
David
Thanks. Update 1.8.0.8 seems to do the trick.
David
 
Hello,
I would love the ability to automatically download trade data for a waypoint, a next system, a targeted system, anything. As of right now it appears I have to dock in order to have the trade data update, unless I do a ton of workarounds. Is there an easy way that I'm missing to pull trade data for any given "unregistered" market? Thank you!
 
Hello,
I would love the ability to automatically download trade data for a waypoint, a next system, a targeted system, anything. As of right now it appears I have to dock in order to have the trade data update, unless I do a ton of workarounds. Is there an easy way that I'm missing to pull trade data for any given "unregistered" market? Thank you!
You can do it by using the build-in EDDB-Relay to download the entire data of all star systems, trade stations, trade data and factions surrounding your location once a day before launching TCE. Enter the Extension tab of the launcher, select the distance of lightyears and lightseconds around your current position and hit the Update buttons.
That's all for a day.
 
You can do it by using the build-in EDDB-Relay to download the entire data of all star systems, trade stations, trade data and factions surrounding your location once a day before launching TCE. Enter the Extension tab of the launcher, select the distance of lightyears and lightseconds around your current position and hit the Update buttons.
That's all for a day.
Even when I do this, I still seem to have issues! I will go back and play around some more with it tonight.
 
Hi Eventure

I'm currently using TCE v1.8.0.8 and following the ED Fleet Carriers update I notice that the station market type is not being picked up by TCE and is consequently resetting all stations to 'None'. I seem to remember that I saw somewhere there were some changes to the ED log file and assume that this may account for the omission.

Also I have noticed for a while that some of the TCE ship hangar stats are resetting after every TCE update, those I have noticed specifically are 'mileage' and 'utilization'.

Thanks and keep up the good work!
 
Hi Eventure

I'm currently using TCE v1.8.0.8 and following the ED Fleet Carriers update I notice that the station market type is not being picked up by TCE and is consequently resetting all stations to 'None'. I seem to remember that I saw somewhere there were some changes to the ED log file and assume that this may account for the omission.

Also I have noticed for a while that some of the TCE ship hangar stats are resetting after every TCE update, those I have noticed specifically are 'mileage' and 'utilization'.

Thanks and keep up the good work!
Confirm (the first part), patch will be released soon.
@Do you update through the launcher or by installing a new version and transfer your database?
 
Last edited:
Confirm (the first part), patch will be released soon.
@Do you update through the launcher or by installing a new version and transfer your database?
I always update via the launcher unless I hit a problem, and then I would install the new version and transfer the database (although I rarely encounter a problem).
 
I always update via the launcher unless I hit a problem, and then I would install the new version and transfer the database (although I rarely encounter a problem).
Thanks for the info.
You encounter the issue every update? Because I have trouble to recreate the issue here, but will continue to look further, if I can find something.
BTW, could you send me a report incl. your player.data file from the CMDR folder? Would like to take a look. Thanks in advance.
 
Last edited:
first of all thank you for your wonderfull tool, for me Tritium is missing. I will think you will patch it soon in.

Or is there another sollution, does it work to add manualy im missing the frontier id.
Mabe someone can provide a pic how to do, or give a tip what to update

thank you all
 
Version [1.8.0.9] released
Changelog:
  • Added Tritium to the commodities database.
  • Fixed an issue with the proper service and economy detection of stations, which have a market when docked.
Notes:
Either download the version above, install and transfer your old database, or use the auto-update function of the launcher.
Click the 'new version' notice at the bottom of the launcher.

If you find an error, please report and use the Report a Bug button at the launcher and don't forget to copy the error details and ErrorReportFile.7z archive.

I like to remind any user, who wants to use TCE in french, spanish or russian to help in translating the
latest interface phrases, common commodities and rare commodities at OneSky. Thanks in advance.
 
Last edited:
first of all thank you for your wonderfull tool, for me Tritium is missing. I will think you will patch it soon in.

Or is there another sollution, does it work to add manualy im missing the frontier id.
Mabe someone can provide a pic how to do, or give a tip what to update

thank you all
Thanks for the feedback, if you required any assistance, please let me know!
@You can add missing commodities quickly by using the Database panel.
 
thank you ill try im missing the frontier refe id and the eddb ref id for Tritium.

can´t add it to the database because those 2 ids are missing so no save button apears
 
Last edited:
thank you ill try im missing the frontier refe id and the eddb ref id for Tritium.

can´t add it to the database because those 2 ids are missing so no save button apears
ED ID is 128961249 and EDDB is 362.
Have updated the above patch with the new ID's actually.
I attached the new resources.db file. Extract it into the DB folder of TCE, if you have updated to 1.8.0.9 before this post.
 

Attachments

Thanks for the info.
You encounter the issue every update? Because I have trouble to recreate the issue here, but will continue to look further, if I can find something.
BTW, could you send me a report incl. your player.data file from the CMDR folder? Would like to take a look. Thanks in advance.
Hi Eventure

It dosen't appear to happen everytime (the playerdata files in the links below are pre & post undate v1.8.0.8 to v1.8.0.9) but it has happened on a number of occasions over the various updates and the update itself appears to be the only possible reason why.

https://www.dropbox.com/s/eg5pxdrglkx83o4/ErrorReportFiles_V1.8.0.8.7z?dl=0
https://www.dropbox.com/s/fjjsde5xp0e4kar/postupdate_player.data?dl=0
https://www.dropbox.com/s/4d2j1smw7fs497r/preupdate_player.data?dl=0

Whilst I have your attention can you please remind me how to delete any duplicate/wrongly spelt markets from the database. I thought at one time that there was an option in the markets panel but I can't find it.

Thanks
 
Hi Eventure

It dosen't appear to happen everytime (the playerdata files in the links below are pre & post undate v1.8.0.8 to v1.8.0.9) but it has happened on a number of occasions over the various updates and the update itself appears to be the only possible reason why.

https://www.dropbox.com/s/eg5pxdrglkx83o4/ErrorReportFiles_V1.8.0.8.7z?dl=0
https://www.dropbox.com/s/fjjsde5xp0e4kar/postupdate_player.data?dl=0
https://www.dropbox.com/s/4d2j1smw7fs497r/preupdate_player.data?dl=0

Whilst I have your attention can you please remind me how to delete any duplicate/wrongly spelt markets from the database. I thought at one time that there was an option in the markets panel but I can't find it.

Thanks
Enter the Database panel, select Trade Markets, Delete Market, then enter the first letter of the market. A list is shown, select the market and hit the Delete Maket button.
 
Enter the Database panel, select Trade Markets, Delete Market, then enter the first letter of the market. A list is shown, select the market and hit the Delete Maket button.
Found it!! Thanks

Sorry to be a pain but on another note I am having problems with TCE's connection to EDMC. As usual I have EDMC open when playing ED and the status shows here as 'Authentication Successful'. However on the TCE extensions screen it shows as 'Invalid Credentials' and when in game when trying to update market details TCE comes up with a 'Login Error' and takes me to my browser to log in with my Frontier ID. Even after logging in here it still does not solve the problem.

My Frontier login details have not changed recently so I am a little confused as to what the problem may be. Hopefully you will be able to come up with an answer 🤞
 
Last edited:
Found it!! Thanks

Sorry to be a pain but on another note I am having problems with TCE's connection to EDMC. As usual I have EDMC open when playing ED and the status shows here as 'Authentication Successful'. However on the TCE extensions screen it shows as 'Invalid Credentials' and when in game when trying to update market details TCE comes up with a 'Login Error' and takes me to my browser to log in with my Frontier ID. Even after logging in here it still does not solve the problem.

My Frontier login details have not changed recently so I am a little confused as to what the problem may be. Hopefully you will be able to come up with an answer 🤞
First off, please use the default font size, it's hard to read your post. I'm getting old...

I can recommend the following to your issue (it's not an issue of TCE, btw):

Here is a step-by-step procedure of authorization:
1. Start EDMC alone to get to the login page to authorize EDMC.
2. Login and approve the authorization once.
3. EDMC should thereafter confirm the success.

This has to be done every update of EDMC.

If you having trouble authorizing EDMC, deauthorize it first here (https://auth.frontierstore.net/).
 
Hey i have a problem... whenever i move the mouse from box to box (icon menu), my ingame controlls takes action and roll my ship... (and im on fokus)

Same thing when im not on focus and roll my ship up then my mouse shows up in the box... its bit annoying in a fight...

can anyone help me?
 
Top Bottom