The GLFrontier Thread

Finally I have my own ship, it’s not much but it’s mine and I have polished my last plasma conduit ever now, feels good to leave that old rusty Transporter behind me. I feel sorry for whomever captain Hubbard is able to recruit to that rusty piece of junk he calls the finest trading ship in the sector.

good opening to a story, conveys a lot of info in not a lot of words:

had dirty & horrible job he hated
now has own ship
the ship he did serve on was old
it was falling apart
his former job was voluntary, not a slave or anything
it was a trading ship with several crew
the character is capable of empathy
the ship he came from stayed in one sector
the captain loved his ship despite its many faults

if you want to turn it from more than just a log into a full blown adventure story check out Drew's writers guide in the fan creations forums
 
I started a new commander in glFFE and will try to write log/journal over his adventures in the elite universe as he try to make it as a new pilot. His dream is probably to own an Imperial Explorer and just explore the galaxy, until then he needs to earn a lot of credits and will probably try a career in trading first and perhaps a military career as well. Makes a bit more fun with a story and just no speed jump between Barnards Star and Sol for a few months of ingame time.



https://grimsqueekers.net/~ratdeath/?p=295

I will try to update this journal at least weekly :)

Frontier:First Encounter is still the best space game at least for another year and a few months :) Hope I don't butcher the English language to much :D

Who knows maybe I am ELITE in both Elite (Amiga) and Frontier: First Encounter (PC) before Elite: Dangerous is released.


A fantastic idea. Looking forward to reading it, oh and your English is EXCELLENT. :)

I tried to go to your link I got a bunch of security warnings.....odd.
 
Last edited:
Probably a most embarrassing question...

OK, so I'll hold my hand up and say that I never played Elite 2, Frontier. I watched my friend play it on his Amiga, but that was as close as I've come...

Soooo I decided, for a giggle to try it using GLFrontier... I've managed to take off (without getting shouted at), travel to Barnards star and dock using auto pilot.Travel back to Merlin, but can I find Sirocco Station to dock at (despite having clearance to land)? Can I heck as like...

So my question to you Frontier veterans is how do I find a space port on a planet?

Many thanks, Eid
 
Fear not my friend, few here have not slapped their own faces upon finally realising how some simple feature of FE2 works.

Use the system orbital map, click on the planet to centre it and zoom in using the magnifier icons. Double click the icon to zoom in all the way. You should see the name of the starport somewhere on the planets surface. Right most icon to select an autopilot target, then click on the starport. If you can't see it, there is an icon to toggle the display of names and sometimes you need to rotate around to get the name to show up.

Once selected you can fly manually to the green square in the HUD or let the autopilot do it. Beware, at normal time/low time acceleration, the autopilot may crash you into the wrong side of the planet to get to the station.
 
bear in mind as well that *sometimes* in Frontier the spaceports and orbiters are a bit buggy in the map view and you may have to rotate or left-click on the screen to make the names appear. Remember that you can right-click and drag to rotate planets, too, if you are looking for a spaceport.
 
Oh, you are using GLfrontier. The single, ONE problem with this version is a known glitch, no matter how many times you click it on your cockpit the system orbital map will never show up. Push F2 TWICE. That should get you to the appropriate screen. Then like MacArthur said, you can zoom the map, in my case I use F7 and F8 instead of clicking the icon. Hope this helped!
 
GL Frontier Photo Mission Bug?

Hi, new user here. Having searched for an answer to this question, I've just realised how small the community is for this fine game.

Anyways, I've been playing GL frontier for a couple of weeks now (bought the original Frontier on Amiga when it came out), but I'm having difficulty finding the target when attempting a photography mission.

I get into orbit, but I just cannot find the 'pixel' target that was visible on the old Amiga version.

I've tried maybe five different missions now, with the same lack of results. Am I missing something stupid, or is it a known bug with the game?

*EDIT*

I've now found my solution on these very forums, sorry for wasting your time.

I discovered that you could revert to original graphics by pressing 'ctrl-e'. When I did this, the pixel appeared, and I got my photographs (and more importantly, my medals... ).

Useful community, you have here... :D
 
Last edited:
Good to know you were able to find your answer with a little digging around.

Anyway, welcome to our little corner of the Internet.
 

Sir.Tj

The Moderator who shall not be Blamed....
Volunteer Moderator
Glad you found the solution, it's a bug that appears in FFE remakes as well and has made me bang my head against the wall on occasion :rolleyes:

It's well worth having a dig around the forum, you'd be amazed what you can find on here :D

Have fun.
 
Yeah, I'm definitely going to have a root around in here.

Frontier is still a great game, 20 years on. I go back to it every few years or so, but I can never hold onto a save game across those years. This time I'm going to make sure I know where my backups are. :D
 
GL version working on modern laptop

OK, I have managed to get the GL version of Elite2 Frontier working on a modern laptop before, but I'm trying again and cannot find out what I am doing wrong. I'm downloading from Tom MOrton's site and the windows binary file say it is a .rar file and cannot find software to open the file and the sound effects is a .tar.bz2.

Also, I'm trying also to use D Fend Reloaded, which seems to automatically load the game in dosbox.

I'm sure I managed somehow before of downloading both the game file, and the sound effects file (extracted to the same directory as the game) then clicking on I think the windows batch file to get the game working. This was the one with the smooth decent quality graphics.
 
IIRC you don't need to invoke DOSBox, it's a stand alone Windows executable. I'm away from my computer so can't verify atm.
 
Hi James
Steve is indeed correct it runs without the need for D-Fend Reloaded. If you need to de-archive it try using 7zip. Remember though that you will need to de-archive the sound effects archive twice to get the music and sfx directories to put alongside the Frontier GL exe. :)
 
I have a similar problem as one of the posters here on this thread - I cannot hear any wind sound, and the engine/thrusters sound is missing (total silence when I travel), but the other sounds work ok (although a bit different compared to the original version - especially the sound of lasers). Any solution to that problem?
 
Top Bottom