Ryzen 2700X & WMR: poor performance, CPU limited regardless of settings.

After a couple of years running Elite in VR on a 970m laptop (yeah it actually worked pretty fine with reprojection in 2017 - 2018) I upgraded to a desktop with the following specs:

Ryzen 7 2700X
RTX 2060S
16GB DDR4
Samsung 860 Evo 1TB
HP WMR headset (1st gen).

While the game runs fine at 90FPS in open space, it runs consistently poorly around stations and any busy instance (say with more than 3 ships present) even dropping below the 45 FPS repro threshold in places like combat zones, especially when other players are present... the weird thing is it seems to be almost entirely irrespective of graphics settings. Using FPSVR to monitor performance, it's consistently my CPU that's struggling. I would say 'maybe my CPU just isn't good enough' but like I said, it used to run acceptably on a considerably worse machine... it doesn't make sense to me that I can now barely even make the reprojection threshold.

I've been juggling settings a bunch (over the past few months actually, I try to get it running then give up, then come back to it, then give up etc.) so I am not sure how useful it would be to post them, but I'm currently trying mostly low/med everything (except volumetric fog to get around the fuzzy asteroid bug), steamVR's resolution scaling disabled/set to native and HMD image quality at 1.25. 1.25 is the lowest I'm willing to go really, as below that it looks garbage - but out of interest I did go down to 1.0... and it still performs poorly anyway so vOv. I know I should probably screengrab the FPSVR/settings etc but I closed everything in a huff... let me know if anything specific would help.

Does anyone have any advice or similar experiences? I bought the headset ostensibly for Elite back in the day but now I've pretty much given up on it, while every other VR title I own runs absolutely fine on high settings across the board.
 
Last edited:
Did you re-install the game/file integrity check it?

From what you are listing it seems your CPU is fine. Did you check system temperatures too? Sure there is no bottleneck due to thermal throttling?
 
Did you re-install the game/file integrity check it?

From what you are listing it seems your CPU is fine. Did you check system temperatures too? Sure there is no bottleneck due to thermal throttling?

Yeah game has been uninstalled/reinstalled several times since I bought the desktop, and verified integrity. I will check temperatures again but I think it was OK, like I said the CPU performs fine in other games and benchmark tests.
 
I just tried again with all settings at their lowest possible, shadows off entirely, HMD image quality 1.25. GPU still barely engaged at all, 90fps in empty space (obviously at this point), CPU temps hovering around 56c... and yet performance issues identical to med/high settings in CZ: barely holding reprojection threshold, dropping below it when capship in instance.

I might not have the absolute best PC In the world, but damn, it's better than this. Do people just not do CZs in VR or something? Driver issues? I'm at a loss.

Edit: tried turning volumetric fog to lowest and HMD image quality down to 1.0 to avoid the jaggy asteroid edges, and if anything it performs... worse.
 
Last edited:
I have an Acer WMR headset which should be functionally identical that I use with a 1080 Ti (moderately faster than a 2060 Super) and 3.8GHz Xeon E5-1660 (a bit slower than a 2700X). Been a while since I looked at performance details, but the only areas I fall below 90fps I'm GPU, not CPU limited.

None of ED's graphics settings do much in CPU limited scenarios, but ED is very rarely CPU limited, even in VR, unless there is an extreme mismatch in CPU/GPU performance or something is wrong. That this is a new system makes me think there is some sort of configuration issue.

Getting a look at the actual per-core CPU utilization while playing would help.
 
If all else fails, try these steps from scratch:
(doing step by step for anybody else looking fix their WMR experience in Elite)

0- Run Elite, temporarily set graphics settings (under custom) to "LOW VR" and even go and set textures to low. Terrain work to far right. Set (monitor) display to a low size, - Windowed - and refresh rate that matches your desktop or laptop monitor. FPS limit to 90 (for your wmr headset). Quit back to desktop

1- in steam library , right-click and choose steamVR (Beta opt-in) and Windows Mixed Reality for SteamVR (no Beta opt-in)

2- make 2 changes in default.vrsettings ( see attached picture for path and changes - make sure there is no "/" ahead of the line you are changing as this disables whatever is written after.).

3- disable any non-essential programs running (browser, FPSVR)

4- plug in your Headset and in the launch Elite

5- when you see the steamVR box appear on your regular monitor (why we had display set to windowed in step 0), click on the 3 bars top left to access settings and set them up like 2nd attached picture. This will allow steamVR to automatically adjust the super sampling as you go. Ensure FOCUS on Elite by clicking mouse on the game screen of your monitor if in windowed mode)

6- once in game, you will have indicator lights at the top left of the headset - GREEN for 90 fps (no reprojection), light-BLUE for CPU bottleneck , darker BLUE for GPU bottleneck (smooth reprojection) and finally RED for not able to sustain minimum frames for smooth reprojection. So unless RED pops up, it will be a smooth VR experience

7- Try to get the indicator to RED if you can by visiting HIGH RES sites and trying to get many ships in a big fight (with the settings as they are, this should not be possible)

8 - Now you can go back into Elite's graphic settings and start increasing any setting until you can get that RED indicator to appear. SteamVR may decrease the auto super sampling as you do this to compensate - so it's up to you to prioritize which ones are important (ex SMAA, Shadows, ambient occlusion etc)
 

Attachments

  • vr settings.png
    vr settings.png
    65.1 KB · Views: 45
  • steamvr.PNG
    steamvr.PNG
    301 KB · Views: 46
Last edited:
Thanks for the responses, both of you.

Since my first post I uninstalled/reinstalled the WMR software/drivers, reinstalled SteamVR and the WMR hook and opted in to both betas, I also did a 'preallocate virtual monitors' registry step I read about in another thread. Then I reinstalled Elite and have seen better performance. It's still dropping into reprojection territory in CZs, and still seems oddly CPU limited according to the WMR monitoring tools, but at least it's not dropping below 45fps anymore so it's playable again and on not-terrible graphics - mostly medium with volumetric fog on ultra. Some of the poor performance was perhaps more a networking issue too, last week we had a wing of 4 up in CZs most nights and the instances were hanging / rubberbanding pretty badly even in flatscreen.

Sadly I didn't do any of the above in a methodical or scientific fashion, I am more of a mash-buttons-frustratedly computer toucher, but next time I run it I will run some monitoring software and take a closer look at my CPU usage. It's not ideal, and I still have the feeling that this PC should be getting better performance out of it, but it's at least back to how it was instead of unspeakably terrible.
 
Top Bottom