Discussion Prevent "all or nothing" joystick usage.

I apologise if this has been covered over and over, but I'm having trouble getting a clear answer.

How do I prevent an "all or nothing" joystick action in regards to performing turns? My Thrustmaster, I'm sure it could once gently and smoothly turn at very slow rates if I applied weak pressure to the stick during combat and fuel scooping around stars, but I moved to a new house, reinstalled my gear and now I have a situation where there's a horrible deadzone before ships begin to turn at a full/maxed fixed rate.

I've checked in the settings and I can't seem to see anything other than deadzone settings for a mouse.

My calibration tool out of game confirms gentle/slight pressures are good, but once in game, no subtly allowed.

Any advice/help would be appreciated.
 
Last edited:
If the stick movements are bound to "buttons" (i.e. fully on / fully off) rather than axes it would give the outcome described in the OP.
That.
Check what you bound your Joystick axes to:
O3UCONJ.png

This is my setting (or at least once was...): the games' axes are bound to the joystick axes. If you instead bind e.g. yaw left/yaw right, you'll get the digital response you described.
 
I've checked in the settings and I can't seem to see anything other than deadzone settings for a mouse.

My calibration tool out of game confirms gentle/slight pressures are good, but once in game, no subtly allowed
Hi,

This would tend to indicate you may have a USB issue.
Your joystick should be reported in 'joy.cpl', if not, resolve this first!.

I do not suppose you recently updated Windows 10? It has an issue which sounds a lot like this...I reverted to 1909 and everything came good.

You might also like to try...
  1. using different USB ports
  2. uninstall/reinstall the Thrustmaster drivers
Let us know how you get on.

Cheers
Clicker
 
Top Bottom