Odyssey Alpha PC Specifications & Download Time

LOL, download started, and finished just inside an hour. The button didnt turn to "Play" and went to a greyed-out "Install" button again, upon restarting the launcher, Odyssey is no longer on the list
Mine is greyed out also. Although I've not closed it down in case it was doing some file checking malarkey.
 
I am the owner of a Lifetime Subscription, but I have no access to the alpha. It hurts. Why did I buy the Life Pass when I have to buy each add-on separately?
And I repeat...

Wahhhhh!!!!!

Heaps of people are having problems getting the download started, but MY issue must be because they are deliberately trying to rip off the LEPers... Despite other LEPers getting the download...

/Wahhh
 
Same here, LEP holder but no download yet on Steam (neither version). I hope they didn't forget about us.
Mine isn't steam - it's straight from Frontier in 2015 - still nowt :(
I suppose they are overwhelmed with downloads and haven't the bandwidth allocated ...
 
Patience... I'm also using the original Frontier install, no Steam. It took a while but after restarting the launcher, it is now showing as an option and started installing the Alpha.
 
My download will be finished in about 30 minutes but my wife now tells me my child needs collecting from school. If anyone's free, his name is Ben and I'll text you the school's address.

Can't you get his sister to do it, or can she not tear herself away from her mining for her carrier friend? :D
 
Just launching from the desktop screen without going into steam worked for me. Well it showed up at least. Good luck commanders! Plus add me i need PC friends i have none at the moment. Wildbill336
 
Might as well add that as a LEP holder I too don't have an option yet. Also, my steam alt has entitlement but not options as of yet. Would be good if FDEV just let us know its being looked at.
 
у меня забрали доступ к обновлению, сначала я получил сообщения о том что (необработанное исключения при обновлений проекта: В экземпляре объекта не задана ссылка на объект)

I was denied access to the update, at first I received messages that (unhandled exceptions during project updates: Object reference is not set in the object instance)
2b62810cb705d9cb36b6fdad691deeaa.png

After restarting the launcher, the alpha odyssey disappeared
a8c5393db46a049d320d803ba85e697a.png
 
Another LEPer here with no alpha and no pre- or post- explanation from Frontier. Typical.
You'd like them to explain why you in particular can't get an immediate download, within an hour of the downloads opening? When there's all sorts of people, LEPers and otherwise, who also can't get the option to show? And while some LEPers say it has worked for them already?
 
Still can't see the option for alpha. I've done what you guys said on steam and still nothing. what? I've checked if I bought deluxe (just to be sure) and I did.
I'd say just be patient then...

Fdev probably still hasn't enabled it for everyone whose supposed to have it; and its likely they're still having some issues on their end as well, as Pre-Alpha launches never seem to go according to plan regardless who the developer is.
 
Top Bottom