I am constantly messing up the scale/measurements of Blender :(

Yes, read above.

I tried to prepare an empty file with correct measurements for PlanCo usage, but I just mess it up, it is both millimeters and lots lots of meters at same time, different in different fill boxes etc.. So messy!

So I wonder, why don't you make a good empty file for us to use, that is correct straight away and is not messed up.

I am adding a file to show what I mean with messed up!View attachment daisy petal ring.zip
 
Yes, read above.

I tried to prepare an empty file with correct measurements for PlanCo usage, but I just mess it up, it is both millimeters and lots lots of meters at same time, different in different fill boxes etc.. So messy!

So I wonder, why don't you make a good empty file for us to use, that is correct straight away and is not messed up.

I am adding a file to show what I mean with messed up!View attachment 2474

You need to setup your scene size before adding any mesh. Prior to add any mesh, go to the scene properties ( I think it is the icon with the 3 coloured balls) and set scene measument to meters.

Everytime I open blender I delete default cube, camera and light and then set scene measurement to meters to avoid any conflict when export it to TMT.
 
I did set the scene measurements to centimeters. (I thought it was the one to use) but everything is like off. Well, nevermind. Maybe if someone take a peek at my file and can see what's wrong.
 
I had a look at your model, this is what I found:

In your scene tab > units, you had wrong settings. This is what it looked like when I opened it:

Error001.png

The fastest way to convert the process is by changing "meters" to "centimeters" as below:

Error002.png

After this you need to scale up your model following these two steps:

1. The main priority is to scale things up by a hundred times in each axis direction (X, Y and Z), since you have gone from meters to CENTImeters. As you do this your viewing distance in Blender grows thin.

2. Change the "End" on the Clip section so that it reaches 100m instead. You can do this by manually typing in 10000. So that it says 1cm towards 100m. That should change your viewing distance.

Error003.png

After you have created your LODs, the Materials assigned to the model with UV-mapping applied, you need to do one final step because you are using Blender.

A common issue with Blender exporting is that the game doesn't recognize Blender's Z-axis as up. This leads to shadows not being applied correctly on your model's surfaces. The figure out-solution to that have been to manually rotate your object aswell in Blender:

-90 degrees on X-axis.
180 degrees on Y-axis.

Then export fbx in ASCII-settings with Y-axis being up and Z-axis being forward.

Personally however, I have come to work with the standard 7.4 Binary fbx-export instead (mainly because that's the only way I got flexicolours to work), but I had to use this axis-rotation instead:

-90 degrees X-axis.
180 degrees Y-axis
180 degrees Z-axis

Exported fbx with 7.4 Binary settings, Y-axis up and -Z-axis forward.

Hope this help! Keep writing in this thread if anything else shows up.
 
Hey :)

you can also select the mesh and change to object mode. Then use ctrl + A and select Scale. This should fit your objects to your scale :)
 
Thank you two!

I watched the tutorial on blender to toolkit. But there it said that assumed we have done the texture+uv-mapping, I am all like.. what? :D Do you have any suggestions on tutorials that would fill that gap for me?
 
Allow me to elaborate:

To create a UV-map you must select all your faces in Edit-mode, which can be selected by clicking on your model's edges, vertices and faces info in the right list. Or going by selecting it on your down left bar:

Error004.png

IF you would want to work with individual faces' texturing you should consider choosing to mark seams on all of your model's edges. You can do so by clicking on Ctrl+E in edit-mode and selecting "Mark seam". However, for this specific model I would not recommend you do so:

Error006.png

Instead I suggest you Unwrap your model directly. In edit-mode, when you have selected all faces (do so by pressing A or manually box-selecting your faces with B) press U. Your first option in the list will be to Unwrap your model. Press it and wait for it to process:

Error005.png

Why I say this way of unwrapping is better for you is because your specific model is created with the thought in mind that all polygons are connected to each other in a flow-like emotion, like a flower pedal.

Next step is opening up "UV/Image editor" by following these steps:

1. Remember to have all of your faces selected in edit mode when opening up your UV-mapping section.
2. This is where you can drag open a new window where you can see your UV/Image editor.
3. Down here is where you'll select the editor.
4. This is where you'll find your desired texture that you wish to use. Just open the folder and find it!

Error007.png

You'll see that the UV-mapping here are shaped just like your model's flower pedals, this is the intended effect in your texturing process as you did not mark the seams of your model. It will help you a lot with texturing.

From this point on you can select vertices and edges in your UV/Image editor to move your texture-mapping around to make it fit your texture properly.

Lemme know if anything else seems unclear.
 
Fantastic thank you!

If I want to color it inside Blender and not use external texture, how would I do?
For example if I marked different sections of different color, and then make it look like for example "translucent" here, and then "glossy" there. (of course named a little differently inside Blender, I forgot exact term) Not this model of course, but for others.

Thank you so much for help so far!
 
Fantastic thank you!

If I want to color it inside Blender and not use external texture, how would I do?
For example if I marked different sections of different color, and then make it look like for example "translucent" here, and then "glossy" there. (of course named a little differently inside Blender, I forgot exact term) Not this model of course, but for others.

Thank you so much for help so far!

I don't think that that it's almost possible without external texture!
You need to have the textures and in blender (or Maya, 3d Max etc.) just your mesh and a UV-map!
 
Oh, I thought it was something like render the result and then unwrap but now I can see why it won't work that way due to the lights and shadows.

but what about the different sections of colors? If I made it so that some faces are this color and some other are that color, it would make it simpler, right? Maybe by adding seams? (I saw some video on unwrapping)
 
Helena, you can export your UV mapped image as a PNG (inside of UV mapping - press mesh, export UV Map) edit it in your photo editor program, then use that as your texture.. I think..
 
Top Bottom