How to install ED on Linux using Wine [EXPERIMENTAL, NOT OFFICIALLY SUPPORTED]

I've been troubled with that today after doing a fresh install of Mint 20.

Do 4 things.
get the latest winetricks version
use winetricks to make sure that DXVK is installed
use winetricks to make sure that DotNet 4 is installed ( dotnet40)
use winecfg to set the windows version to win7

Then it should run

In Wine 6.0 Stable I find that the launcher is often black but you can still type in your username and password and authentication code.
I know the launcher is effectively a simple web browser in the way it displays info so if anyone has a fix for the black launcher then please let us know :)

This should help: custom wine mono build

Now... The game freezes at main menu. What should I do with it?
 
It works again. I tried the custom mono and the standard mono from winehq but EDLaunch.exe would not run at all unless dotnet40 was installed. The black launcher seems to be a quirk of Wine 6 in Mint 20. It does show window components when you move the mouse over them. But most ly it looks like this:

launcher.png
 
That black launcher happens for me too on Arch Linux. IIRC it went black after installing arial fonts or corefonts, and without those fonts the launcher crashed after typing in username and switching to password field. But it still works even if it's black, some elements do show on mouseover, and tabbing worked when typing in login creds.
 
That black launcher happens for me too on Arch Linux. IIRC it went black after installing arial fonts or corefonts, and without those fonts the launcher crashed after typing in username and switching to password field. But it still works even if it's black, some elements do show on mouseover, and tabbing worked when typing in login creds.
That's exactly my experience. It works on mouse over and I can still type in the fields. The launcher looks correct in wine-staging but wine staging causes random pauses of 5 to 10 seconds ( heart stopping when you're exploring in a sidewinder )
 
That's exactly my experience. It works on mouse over and I can still type in the fields. The launcher looks correct in wine-staging but wine staging causes random pauses of 5 to 10 seconds ( heart stopping when you're exploring in a sidewinder )
I use archlinux and the launcher is fine. I installed the wine-mono, but kept the dotnet and it worked for me
 
Well I used: lutris-5.6, lutris-5.21, lutris-5.7.11, lutris-5.7.10, proton-ge-5.9, proton-5.13, and system (6.0)
Wine Stable 6.0 should work but you may get the black launcher as per my pic - it's not crashed and does work. Just not fully functional in terms of display. Make sure you have dotnet40 and dxvk installed. Though I must say I am using Mint rather than Arch and I don't know the differences between them. My personal preference is for Debian based distros.
 
Wine Stable 6.0 should work but you may get the black launcher as per my pic - it's not crashed and does work. Just not fully functional in terms of display. Make sure you have dotnet40 and dxvk installed. Though I must say I am using Mint rather than Arch and I don't know the differences between them. My personal preference is for Debian based distros.

Have you tried the /steam /novr switches when running the launcher? (i.e. wine64 Edlaunch.exe /steam /novr)

Also - do you by chance have a multi monitor setup? I have a dual-monitor setup and for $reasons all sorts of game launchers go haywire if displayed on the 2nd monitor. Moving them to the primary monitor solves it. Still trying to figure out what causes that - whether it's an Xorg, nvidia driver, or some other issue.
 
Have you tried the /steam /novr switches when running the launcher? (i.e. wine64 Edlaunch.exe /steam /novr)

Also - do you by chance have a multi monitor setup? I have a dual-monitor setup and for $reasons all sorts of game launchers go haywire if displayed on the 2nd monitor. Moving them to the primary monitor solves it. Still trying to figure out what causes that - whether it's an Xorg, nvidia driver, or some other issue.
If that's to me - I'm not using steam / proton, I just run EDLaunch.exe straight in Wine ( I have 2 EDLaunch one for each account as my pair of accounts are old ). I play in a borderless window. It makes no difference which monitor the launcher is on. The game itself plays fine.
 
If that's to me - I'm not using steam / proton, I just run EDLaunch.exe straight in Wine ( I have 2 EDLaunch one for each account as my pair of accounts are old ). I play in a borderless window. It makes no difference which monitor the launcher is on. The game itself plays fine.

Yes it was to you :)

And yes I was referring specifically to the launcher. I run EDLaunch from the command line and add the /steam and /novr switches - that's what I was asking, if you've tried that, it might solve the launcher display problem. I don't get that problem.

Rgds.
 
Yes it was to you :)

And yes I was referring specifically to the launcher. I run EDLaunch from the command line and add the /steam and /novr switches - that's what I was asking, if you've tried that, it might solve the launcher display problem. I don't get that problem.

Rgds.
Ahh cool. What does the /steam switch do? I will definitely give it a try all the same.
 
Ahh cool. What does the /steam switch do? I will definitely give it a try all the same.
The /steam option makes the launcher think it is launched by the steam.
This seems to trigger a different render method inside the launcher, solving the blackness/rendering problems in wine.
Downside is that it also expects that steam will do the game updates for it, so there's no update button or it doesn't work (can't quite remember which).
Either way you will need to remove the /steam option in order to perform a game update.

Another solution I've found is to change one of the dxvk settings by placing a dxvk.conf file in the same folder as EDLaunch.exe.
The dxvk.conf as a single line in it with: d3d9.shaderModel = 1
This also results in a properly rendering game launcher, without the need for the /steam option.
I've checked the dxvk logs and this only effects the launcher and not the game it self (the game uses dx11).

Personally I run the EDLaunch.exe with just two options : /autorun and /autoquit.
The first causes the launcher to automatically start the game, so no need to manually press the play button. Unless a game update is required, then it just show the launcher (where I can press the update button).
The second options closes the launcher after I exit Elite.
 
The /steam option makes the launcher think it is launched by the steam.
This seems to trigger a different render method inside the launcher, solving the blackness/rendering problems in wine.
Downside is that it also expects that steam will do the game updates for it, so there's no update button or it doesn't work (can't quite remember which).
Either way you will need to remove the /steam option in order to perform a game update.

Another solution I've found is to change one of the dxvk settings by placing a dxvk.conf file in the same folder as EDLaunch.exe.
The dxvk.conf as a single line in it with: d3d9.shaderModel = 1
This also results in a properly rendering game launcher, without the need for the /steam option.
I've checked the dxvk logs and this only effects the launcher and not the game it self (the game uses dx11).

Personally I run the EDLaunch.exe with just two options : /autorun and /autoquit.
The first causes the launcher to automatically start the game, so no need to manually press the play button. Unless a game update is required, then it just show the launcher (where I can press the update button).
The second options closes the launcher after I exit Elite.
That /steam actually worked a treat! I think I'm going to go with your dxvk.conf workaround as I use 2 launchers, one for each of my two accounts and I can avoid using the terminal that way.
 
Hello.
I installed Elite Dangerous through Steam on my Manjaro Linux.
For control I want use Thrustmaster T-Flight Hotas X.
The joystick is displayed correctly with
Code:
jstest /dev/input/js0
In wine control can I see the Joystick.
2021-02-02_16-19.jpg

But in Steam it shows up as a gamepad, so I can't use the Z-Axis.
2021-02-02_16-22.jpg

Has anybody this problem before and how can I fix it?

Sorry for my bad english.
 
Last edited:
Hello.
I installed Elite Dangerous through Steam on my Manjaro Linux.
For control I want use Thrustmaster T-Flight Hotas X.
The joystick is displayed correctly with
Code:
jstest /dev/input/js0
In wine control can I see the Joystick.
View attachment 206655
But in Steam it shows up as a gamepad, so I can't use the Z-Axis.
View attachment 206656
Has anybody this problem before and how can I fix it?

Sorry for my bad english.

Are you trying to set up the controls in Steam? I don't have this issue and I've never looked at the controller options for Elite Dangerous in Steam. I just go straight to the in game options and set each axis and button up there. For example - I click on Yaw axis and then twist the stick and it shows in the game control profile as Joystick RZ ( or similar )

I've used the HOTAS TFlight X and the MS Sidewinder FFB2 joysticks to play Elite Dangerous without issue in Mint / Ubuntu.
 
@Peppermint Barnstorm
Thx for your answer.
I can only set Buttons in Game, which I have define in Steam. For example I can set the X Axis, because the Gamepad in Steam has a X Axis. But I can't set the Z Axis for example for throttle, because the Steam Gamepad has no Z Axis.

Can you look in Steam is Joystick correct identifed?
 
Top Bottom