How to install ED on Linux using Wine [EXPERIMENTAL, NOT OFFICIALLY SUPPORTED]

i have elite running on Manjaro using a xbox one s controller, controller is picked on steam but the game does not see it, anyone been down this rabbit hole?
 
Since ED is free for now on the epic game store, I grabbed it and tried to use it with legendary (https://github.com/derrod/legendary) and wine. I used the wine-mono fork from @RedMcG. Installation with legendary works. Launching the EDLauncher manually works as well and I get the dialog to login.

If I start the Launcher with legendary however, it passes the epic login details to the launcher and it crashes. It seems to load an additional DLL that doesn't get loaded without the epic login.

Code:
[00000024:] EXCEPTION handling: System.DllNotFoundException: EOSSDK-Win64-Shipping.dll assembly:<unknown assembly> type:<unknown type> member:(null)

It looks like this is a 64bit DLL, while the others seem to be 32bit. I'm not sure if this is the reason for the error.

Code:
$ file *.dll
CBViewModel.dll:           PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
ClientSupport.dll:         PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
EosIF.dll:                 PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
EosSdk.dll:                PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
EOSSDK-Win64-Shipping.dll: PE32+ executable (DLL) (console) x86-64, for MS Windows
FilePackage.dll:           PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
FORCServerSupport.dll:     PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
FrontierSupport.dll:       PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
LocalResources.dll:        PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
SteamIF.dll:               PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows

If anyone has any hints how to debug this further they would be very welcome.
 
Last edited:
Just referencing the steam client... Not talking about epic launcher here..
I've yet to be able to run proton 5.13 with the custom built mono's (latest one tested being wine-mono-5.1.1.2_ED-x86.msi) and be able to get the login functionality to work on the launcher. Only the default steam account login works. The dropdown to logout and log in a separate account never appears when clicking where you should.

Additionally, performance while using the steam login with 5.13 is worse than proton 5.0 branch. I see artifacts in the graphics rendering that i dont see in the 5.0 branch and framerate is not any better as tested with steamVR. Though, 5.0 is pretty flawless so I'm not in any rush to get 5.13 working.

I wouldn't be convinced the problem is not related to proton 5.13 and the custom mono. Have you tried 5.0 and dotnet4 ?
 
It looks like this is a 64bit DLL, while the others seem to be 32bit. I'm not sure if this is the reason for the error.

Code:
$ file *.dll
CBViewModel.dll:           PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
ClientSupport.dll:         PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
EosIF.dll:                 PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
EosSdk.dll:                PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
EOSSDK-Win64-Shipping.dll: PE32+ executable (DLL) (console) x86-64, for MS Windows
FilePackage.dll:           PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
FORCServerSupport.dll:     PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
FrontierSupport.dll:       PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
LocalResources.dll:        PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows
SteamIF.dll:               PE32 executable (DLL) (console) Intel 80386 Mono/.Net assembly, for MS Windows

If anyone has any hints how to debug this further they would be very welcome.

Because these are Mono/.Net assemblies - they'll run as either 32 bit or 64 bit. If you use
Code:
wine64
instead of
Code:
wine
; the assemblies will run as 64bit.

I'm not familiar with Epic or Legendary - so how are you launching the game?
 
Code:
wine64
I always thought that was just a symlink to wine, but this actually changed the behavior. Now mono crashes when it looks like it wants to redirect me to a website to link the accounts. Will see if I can link them with dotnet instead of mono.

I'm not familiar with Epic or Legendary - so how are you launching the game?

Code:
legendary launch --wine /usr/bin/wine64 --wine-prefix $WINEPREFIX $GAMEID

I don't like the Epic store, but legendary is quite nice and the game was free there, so.. 🤷‍♂️
 
In regards to the console based min-launcher alternative:
It sounds like it doesn't allow logging into secondary accounts (accounts not attached to your game portal login ). That's unfortunately a deal breaker for me
 
Hi, anyone
i launched ED whith one little problem. Game freezes on 5-15-20 second when you fly or make other activity in game. On console it is

Code:
0324:err:sync:RtlpWaitForCriticalSection section 00000000019E1860 "?" wait timed out in thread 0324, blocked by 0000, retrying (60 sec)
ED not the only one game who make this error. i dont know how fix that...
 
Hi, anyone
i launched ED whith one little problem. Game freezes on 5-15-20 second when you fly or make other activity in game. On console it is

Code:
0324:err:sync:RtlpWaitForCriticalSection section 00000000019E1860 "?" wait timed out in thread 0324, blocked by 0000, retrying (60 sec)
ED not the only one game who make this error. i dont know how fix that...

Are you using wine-staging perchance?

I was using that on Arch Linux and had the same result as you. When I switched to the not-staging Wine 6.0 package, that went away.
 
Hello,
I need a little help
I have successfully installed the game with lutris and it works very well
But when i clic on the "options" button in the launcher nothing happens
So i just cannot change the language......
And i am french but i admit that elite dangerous in his french version is just a terrible thing that can makes you real nightmares.....
So do you know if i can change the language to English by editing a configuration file ?
Thank you if you can help, you'll save my life !
 
Hello,
I need a little help
I have successfully installed the game with lutris and it works very well
But when i clic on the "options" button in the launcher nothing happens
So i just cannot change the language......
And i am french but i admit that elite dangerous in his french version is just a terrible thing that can makes you real nightmares.....
So do you know if i can change the language to English by editing a configuration file ?
Thank you if you can help, you'll save my life !

i found this: <Language Value="English" />

in C:\Users\znort\AppData\Local\Frontier Developments\Elite Dangerous\Options\Player\custom.misc

maybe you could try that.
 
Thanks you
Finally i have find
Had to put "language override option" to 1 in custom.misc file
Thanks you i am really happy !! Everything is perfect now...
 
Hello, I used lutris to install the game (worked before, then I uninstalled and this new installation doesn't work), epic games, and when I launch the game I get error as in the picture. What can I do with it?
1611869612200.png
 
Hello, I used lutris to install the game (worked before, then I uninstalled and this new installation doesn't work), epic games, and when I launch the game I get error as in the picture. What can I do with it?
View attachment 206028
I've been troubled with that today after doing a fresh install of Mint 20.

Do 4 things.
get the latest winetricks version
use winetricks to make sure that DXVK is installed
use winetricks to make sure that DotNet 4 is installed ( dotnet40)
use winecfg to set the windows version to win7

Then it should run

In Wine 6.0 Stable I find that the launcher is often black but you can still type in your username and password and authentication code.
I know the launcher is effectively a simple web browser in the way it displays info so if anyone has a fix for the black launcher then please let us know :)
 
Top Bottom