Flexi Colour not working


I'm trying to get flexi colour mapping to work on a simple object but it doesn't want to work in-game. These are my set-ups:


This is how I believe it is supposed to be done. Below is the folder setup and etc:




And this is how it appears in-game:


I feel like this should work but unfortunately it doesn´t??
jea looks alright to me. should work. as lucasup said check the material naming. I see Texture_01 and Texture_02 but 1 Material is enough. so Hearth_Material and the textures should be named: Hearth_Material_BC and Hearth_Material_F1 then it should work.

if you have 2 materials you could add 2 different texture sets but since we can already go up to 2k texture size it is not nesessary to use 2 texture sets.
@ lucasup I did try to remove the textures from the blender fbx and it worked once (I then exported in 7.4 binary). When I tried again to do the exact same thing with ASCII it didn't work.
I did remove textures from the blender fbx and it did actually work (difference was I had exported it in 7.4 binary). When I try to export it in in ASCII instead the flexi colour stops working. Is this intended? Nothing makes sense.


So as it turns out, the exporting and uploading process works flawlessly with 7.4 binary. The main difference for Blender export is that you have to rotate you object along the Z-axis 180 degrees aswell. Which would make the setup look something like this:


And in-game it would end up like this with both working flexi-colour maps AND shadows:


Not sure if there is any good reason for using the ASCII export process because as I see it it is absolute crap for me.
Last edited:
@ShoxDanger Not sure what you mean. I have already scaled up my model to the correct size. You kno', don't try to fix something that ain't broken. [wink]
@ShoxDanger Not sure what you mean. I have already scaled up my model to the correct size. You kno', don't try to fix something that ain't broken. [wink]

what i mean is that your model has a rotation and scale value and its best as it is 0 on the xyz.

but yes you got a point if it works it works :D :D
I'm really curious if you have the lighting issue as described in this thread:
I have not been able to rid of this lighting issue without using ASCII export

Or if somehow having a rotation value not zeroed out actually fixes this issue... I'm investigating but can you try rotating your box in-game a bunch of different ways to see if it gets darker in nonsense directions (Like just being flipped 180 makes it darker) or not?

HMMMM. It seems like having a rotational value like this DOES FIX THE LIGHTING ISSUE.
I specifically tried matching your screenshot of having rotation values of -90, 180, 180 and that worked.
This is so bizzare. I'm going to have to do a bit more investigation but aaaaaaaaaaaa
Last edited:
The rotation:

-90 degrees X-axis
180 degrees Y-axis
180 degrees Z-axis

This works without fault for me using 7.4 binary export. No issues with shadows when rotating the object around all 3 axes, and no issues with flexicolour maps or other additions (RN, SM and so on). There may even be a less complicated way, but for now this is what I'll be using.
Top Bottom