My elite chroma stopped working for me, it shows up in the taskbar, and i have all the correct paths, but unfortunately it doesnt change the lighting, synapse doesnt recognize elite chroma in chroma connect either. help :(

Thank you for reporting. Sorry for answering with such a delay, but I rarely receive notifications when someone posts in here.

Open Synapse 3, go to "Chroma Connect", and ensure that EliteChroma appears in the list and that it's enabled (with a green circle).

Also please be sure to download the latest release, just in case.
 
A cool idea you could maybe add is when you have your hardpoints out, all keys become red

I do provide feedback for deployed hardpoints, but it's applied anywhere but the keyboard. The keyboard is already bloated with colors, so I didn't want to add more to the clutter. However, I'll think of some animation that conveys the same meaning. I've created issue #79 on GitHub to track this.

and maybe flash when you're running low on Weapon Power

I'm afraid that the game doesn't provide that kind of information, so I'm unable to to anything.

And the whole keyboard can flash blue then wipe to black from the centre to indicate your shields have gone down.

I actually like this one! I've created issue #80 on GitHub to track it. Thanks!
 
Anybody with a Razer keyboard that isn't using vr should definitely be using this!
Been using Elite Chroma since it's initial release and I cant stand playing without it being in use, the video seriously doesn't do it justice. The extra level of immersion works really well, i'm often so engrossed that I don't see or hear in game alerts but a flashing red keyboard soon brings you back to focus, things like visual indicators for lights, landing gear etc are an added nice touch, I never forget to retract stuff anymore.

If i had any criticism at all it would be that in the latest release the colours seem a bit washed out, most notably for me when fuel scooping, previously it was a nice deep orange colour washing across the keyboard, the latest rlease seems to have changed to a pale ish yellow, but Elrith often implements feedback so i will test some more to rule out my setup before saying its the new release for sure.
 
Anybody with a Razer keyboard that isn't using vr should definitely be using this!

I'm really glad that you like it. Thanks!

If i had any criticism at all it would be that in the latest release the colours seem a bit washed out...

Indeed, I made changes to many colors on version 1.10.0. I recently treated myself with a couple of Philips Hue colored light bulbs, and the previous setup made the bulbs render heavily saturated colors (e.g. fuel scooping's deep orange color looked like a very strong red-orange shade on light bulbs). Hence, I went through all the hard-coded colors and adjusted them so the light bulbs looked closer to the game representation. Unfortunately, as you stated, the keyboard now looks very washed out.

I'm thinking on applying different saturation levels to Razer devices and ChromaLink (e.g. Philips Hue devices), but I have yet to figure out the best way of doing it. I'm worried how this change would affect other ChromaLink devices (like Nanoleaf panels).

I've created issue #91 on GitHub to track this. Thanks again for your feedback!
 
Hi there!

Brand new player here and went looking for Chroma support right away, finding your app. Thanks for putting it together and sharing!

I'm having an issue where it's not recognizing my options folder. Initially it can't find the game folder either since I have it installed on a different drive. Pointing it to the game folder works ok, the red X disappears there. But manually changing Options isn't working. I seem to be pointing it to the correct folder, but it won't accept it. It has the \Bindings, \Graphics, etc as sub-folders so I think it's right... I also tried installing some older versions of EliteChroma since someone earlier in the thread suggested it, and I've rebooted multiple times. No luck.

Any ideas what could be going on? It's the version from Epic Games Store in case that might matter somehow.

Thanks!
 
Last edited:
Brand new player here and went looking for Chroma support right away, finding your app. Thanks for putting it together and sharing!

Thanks!

I'm having an issue where it's not recognizing my options folder...

EliteChroma looks for the following in the Options folder:
  • The "StartPreset.start" file in the "Bindings" subfolder, and
  • The "GraphicsConfigurationOverride.xml" file in the "Graphics" subfolder.
Can you confirm?
 
EliteChroma looks for the following in the Options folder:
  • The "StartPreset.start" file in the "Bindings" subfolder, and
  • The "GraphicsConfigurationOverride.xml" file in the "Graphics" subfolder.
Can you confirm?
I finally got it to work using the time honored tradition of continuous fiddling. I tried pointing it to the folder while the game was running and I guess that did it? It all of a sudden found what it was looking for and started working. It's very good!
 
Stumbled on this while looking for other tools. Thanks for taking the time to make this! Looks great on my BlackWidow Elite Keyboard!
 
Installed everything without a problem, but it doesn't connect to my Synapse at all. Doesn't display as a Chroma App and it doesn't work in-game, yet it still shows up in my system tray. Reinstalled EliteChroma and Synapse but neither fixed my problem. I feel like it might just be Synapse but I have my Visualizer and another game show up in the Chroma Connect tab. Any ideas?
 
Installed everything without a problem, but it doesn't connect to my Synapse at all. Doesn't display as a Chroma App and it doesn't work in-game, yet it still shows up in my system tray. Reinstalled EliteChroma and Synapse but neither fixed my problem. I feel like it might just be Synapse but I have my Visualizer and another game show up in the Chroma Connect tab. Any ideas?

Thank you for reporting this.

Please take a look at this issue in GitHub: https://github.com/poveden/EliteChroma/issues/94, and try the suggestions written there. Come back and tell me if any of it worked for you or not.
 
i can honestly say that whilst playing edo i miss the keyboard reacting via the app. I actually prefer playing horizons so i can still have the keyboard react to the game :D
 
i can honestly say that whilst playing edo i miss the keyboard reacting via the app. I actually prefer playing horizons so i can still have the keyboard react to the game :D

You should be able to use EliteChroma in both Horizons and Odyssey. Just make sure that you are pointing to the right game installation folder in EliteChroma's settings.

I've just pushed version 1.12.0, which fixes an error that occurred while running Odyssey, and makes game selection a little bit easier. Please let me know if it works for you.
 
You should be able to use EliteChroma in both Horizons and Odyssey. Just make sure that you are pointing to the right game installation folder in EliteChroma's settings.

I've just pushed version 1.12.0, which fixes an error that occurred while running Odyssey, and makes game selection a little bit easier. Please let me know if it works for you.
Elrith you sir are a legend, i hadn't thought to try that. The simplest things elude me some days, now i need a reason to take a day off work so i can play :D
 
Hello, it's me from the Youtube comment section. I opened up Event Viewer and this is the error it gives me.

Application: EliteChroma.exe
CoreCLR Version: 4.700.21.21202
.NET Core Version: 3.1.15
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Xml.XmlException: Unexpected end of file has occurred. The following elements are not closed: GraphicsConfig. Line 2, position 17.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.Throw(String res, String arg)
at System.Xml.XmlTextReaderImpl.ThrowUnclosedElements()
at System.Xml.XmlTextReaderImpl.ParseElementContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.Linq.XContainer.ReadContentFrom(XmlReader r)
at System.Xml.Linq.XContainer.ReadContentFrom(XmlReader r, LoadOptions o)
at System.Xml.Linq.XDocument.Load(XmlReader reader, LoadOptions options)
at System.Xml.Linq.XDocument.Load(Stream stream, LoadOptions options)
at System.Xml.Linq.XDocument.Load(Stream stream)
at EliteFiles.Graphics.GraphicsConfig.FromFile(String path) in D:\Dev\GitHub\poveden\EliteChroma\src\EliteFiles\Graphics\GraphicsConfig.cs:line 44
at EliteFiles.Graphics.GraphicsConfigWatcher.<Reload>b__15_1() in D:\Dev\GitHub\poveden\EliteChroma\src\EliteFiles\Graphics\GraphicsConfigWatcher.cs:line 108
at EliteFiles.Internal.FileOperations.RetryIfNull[T](Func`1 action, Int32 retries) in D:\Dev\GitHub\poveden\EliteChroma\src\EliteFiles\Internal\FileOperations.cs:line 11
at EliteFiles.Graphics.GraphicsConfigWatcher.Reload() in D:\Dev\GitHub\poveden\EliteChroma\src\EliteFiles\Graphics\GraphicsConfigWatcher.cs:line 107
at EliteFiles.Graphics.GraphicsConfigWatcher.Start() in D:\Dev\GitHub\poveden\EliteChroma\src\EliteFiles\Graphics\GraphicsConfigWatcher.cs:line 60
at EliteChroma.Elite.GameStateWatcher.Start() in D:\Dev\GitHub\poveden\EliteChroma\src\EliteChroma.Core\Elite\GameStateWatcher.cs:line 98
at EliteChroma.Core.ChromaController.Start() in D:\Dev\GitHub\poveden\EliteChroma\src\EliteChroma.Core\ChromaController.cs:line 103
at EliteChroma.AppContext.CycleChromaController(AppSettings settings) in D:\Dev\GitHub\poveden\EliteChroma\src\EliteChroma\AppContext.cs:line 146
at EliteChroma.AppContext.Start() in D:\Dev\GitHub\poveden\EliteChroma\src\EliteChroma\AppContext.cs:line 67
at EliteChroma.Program.Main() in D:\Dev\GitHub\poveden\EliteChroma\src\EliteChroma\Program.cs:line 38

I tried finding the directory it labels, thinking it was created as a result of the installation, but it is not there. Is that perhaps the issue?
 
Hello, it's me from the Youtube comment section. I opened up Event Viewer and this is the error it gives me.

...

I tried finding the directory it labels, thinking it was created as a result of the installation, but it is not there. Is that perhaps the issue?

Hi! Don't pay attention to those paths, as they point to source code files on my machine, and help me identify the issue.

Your error points to a malformed GraphicsConfigurationOverride.xml file. Specifically:

Unexpected end of file has occurred. The following elements are not closed: GraphicsConfig. Line 2, position 17.

I'm guessing that you edited that file directly, or via a tool to customize your HUD colors. Just fix that file (usually located in the %LOCALAPPDATA%\Frontier Developments\Elite Dangerous\Options\Graphics folder), and you should be good to go.

This crash reason is very common (I'm tracking it on Issue 67 at GitHub). When I get some time I will make EliteChroma more resistant to such files.
 
This is awesome! I was posting about how i might to go about doing this on reddit, but also did some research, et voila! You've done it! Brilliant! I'm hoping that i can get a yeelight led strip + razer chroma + your add-on to work. Just gotta get thevstrip in the next couple of days and start tinkering.
 
This is awesome! I was posting about how i might to go about doing this on reddit, but also did some research, et voila! You've done it! Brilliant! I'm hoping that i can get a yeelight led strip + razer chroma + your add-on to work. Just gotta get thevstrip in the next couple of days and start tinkering.
Thanks! Please don't hesitate to come back if you have any suggestions.
 
Yeelight arriving tomorrow! Clearing shelf space in readiness for install (after basic tests).
Here are the thoughts i bashed out over on reddit, (sounds like you might have covered most of the events).

E.g. switch to orange for exploration mode Blue for combat mode, Solid Red when under attack, Fading red for proximity warnings, "Landing gear retracted" "Warning, temperature critical".
Average docking bay/hangar colour when inside.

I just want to bring the cockpit environment into my room, rather than colour a keyboard.

So excited to get this going!
 
Hi Elrith.
The yeelight strip arrived today and whilst i have synapse 3 + yeelight chroma connector and elitechroma installed, elitechroma isn't showing in the connector app list (as mentioned earlier in the thread), i can't even browse to elitechroma to add it.
(screenshot attached to show elitechroma, elite dangerous, razer connect and yeelight chroma connector all running, but with an empty list of chroma connect app list)

(i tested using the ambient mirror/match setting in chroma studio whilst playing elite odyssey. I wasn't expecting it to work out of the box, but went through the install steps just to test and see what happened.)

Where's best to talk to you further about this? Here or on the guthub page?
 

Attachments

  • EliteChroma_not appearing screengrab.PNG
    EliteChroma_not appearing screengrab.PNG
    904.3 KB · Views: 4
Last edited:
Top Bottom