Release EDSY - The ship outfitting tool formerly known as E:D Shipyard; reimagined, redesigned, reborn

Updated to v3.7.5.5:
  • fixed a bug that made the stored build delete (trashcan) button in the outfitting panel ineffective; thanks oztrich for the report
  • fixed a bug that ignored military slots during retrofit analysis; thanks Cometborne for the report
 
Updated to v3.7.5.6:
  • improved shortlink generation to create local links (edsy.org/s/...)
  • added option to use Current Build as the basis and not only the target of a retrofit analysis (thanks Cometborne)
  • changed falloff range attribute order to be listed right after maximum range (thanks lunarplasma)
 
Hi, had an Idea for a change/addition that might help people with long/longer "Build" names:

I have several builds I store and have more than one characters, so I use some extra letters on my build names to keep track of which is which.

Basically, something like this:


[H:H]"Dragoon MK II"-Exploration


... and sometimes a little longer.

Problem is, with some names they get cut short because of the layout of the site. Usually not a problem, but sometimes it can be.


I noticed in your coding/HTML you have a part like this with the build names: (Basically the coding that shows the build name and makes it a clickable link)

Code:
<button name="storedbuild_reload" value="48346846834658346583465" class="label">BUILD NAME</button>

If you were to change it to something like:

Code:
<button name="storedbuild_reload" value="48346846834658346583465" class="label" title="BUILD NAME">BUILD NAME</button>

Anytime the name is shortened for the link/display area, hovering over it will still show the full build name. One catch would be if the name has quotes in it (like I use) you would need to use code to auto-change it to use the HTML code equivalents.

Such as:

Code:
&quot; for "

(quote marks)


Hopefully I am making sense.

Trying to be clear and explain it, but realize I might be just confusing you. lol

If need to I can share more HTML coding I worked with; copied some of EDSY site coding to do a quick test; so I have the HTML file I could show.
 
If you were to change it to something like:
Code:
<button name="storedbuild_reload" value="48346846834658346583465" class="label" title="BUILD NAME">BUILD NAME</button>
Anytime the name is shortened for the link/display area, hovering over it will still show the full build name.
That's a great idea; very simple to do and I can definitely see the value for your use case. It'll probably be in the next update. Thanks!
 
Hello I hope this is the right spot for this. I have been trying to use EDSY the past few days and I keep getting this error.

"EDSY-FDAPI connector error 0

You can try re-authorizing EDSY's API access, but if the
error persists then there may be a temporary API outage."

This happens when I try to authorize. I have Inara and EDMC linked and they seem to be working fine, any help is appreciated! (Love EDSY btw, thanks for all the hard work).
 
"EDSY-FDAPI connector error 0" means EDSY tried to make a javascript XMLHttpRequest() to a server-side FDAPI gateway script, and got back HTTP status code 0 (undefined) rather than 200 (OK). Status code 0 suggests to me that it didn't even try to send the request, which probably means your browser security settings stopped it for some reason. It works for me (in Firefox 85.0 on Linux Mint 20 with uBlock Origin installed), so I'm not sure what would be blocking it for you.
 
"EDSY-FDAPI connector error 0" means EDSY tried to make a javascript XMLHttpRequest() to a server-side FDAPI gateway script, and got back HTTP status code 0 (undefined) rather than 200 (OK). Status code 0 suggests to me that it didn't even try to send the request, which probably means your browser security settings stopped it for some reason. It works for me (in Firefox 85.0 on Linux Mint 20 with uBlock Origin installed), so I'm not sure what would be blocking it for you.
I have messed around with some settings but still cant get it to work, I did however get it to load ships if I click the ship link in Ed:Market Connector it will load in into EDSY. I use whatever ad blocker is default in google.
 
Am learning how to use this - very nice, and does some things much better than Coriolis.
I just hit a weirdness though: it doesn't seem to recognise military slots as being restricted in any way. Has there been a regression? (Earlier posts imply this should work fine.)
 
Am learning how to use this - very nice, and does some things much better than Coriolis.
I just hit a weirdness though: it doesn't seem to recognise military slots as being restricted in any way. Has there been a regression? (Earlier posts imply this should work fine.)

Go into "Help" and under "Options" make sure you don't have "Experimental Mode" enable. As I just went there and the Military slots are restricted properly for me.
 
Go into "Help" and under "Options" make sure you don't have "Experimental Mode" enable. As I just went there and the Military slots are restricted properly for me.
Thanks. I already checked that and it was off. I will have a play with deliberately enabling it...
Edit: yeah that made no difference. Even in experimental mode it's supposed to show the illegal modules in red but that isn't happening. The version I'm getting is 3.7.5.6 - same as you?
Pic of the optional slots for the Anaconda (looks identical with experimental mode on/off):
1614360928327.png
 
Thanks. I already checked that and it was off. I will have a play with deliberately enabling it...
Edit: yeah that made no difference. Even in experimental mode it's supposed to show the illegal modules in red but that isn't happening. The version I'm getting is 3.7.5.6 - same as you?
1614365072380.png
 
OMFG. Thanks! I'm so used to the Coriolis layout (and so unused to EDSY!) that I just didn't see it. There is a shedload of info on the screen and I guess I need to review it more carefully :ROFLMAO:

I was going to suggest that about the different sections, but assumed the different sections was already noticed... lol
 
I'm back! :D Another weirdness, which might be a bug but is instead presumably another misunderstanding on my part...

I'm trying to improve the engineering on my weapons.
The first pic within the spoiler below shows the hardpoints with the EPS column turned on - the tooltip is highlighted in yellow at the bottom of the pic. (In my head, "weapons capacitor draw" is synonymous with "distributor draw [from the WEP side]", but this may be wrong and might be at the root of the issue below.)

The second and third pics show the detailed info for the top two weapons - the 4A and (first) 3C multicannons, including distributor draw and just plain "power draw".
What's confusing me is that the distributor draw for the (efficient) class 4 gun is around 0.2 MW, i.e. around 60% as much as the 0.34 MW distributor draw for the (overcharged) class 3 gun. But the EPS figures are around a factor of 3 apart, at 0.69 MW/s* and 2.25 MW/s. So... confused. In reality I guess there's a lot going on beyond just draining the WEP capacitor but in this instance, that's what I'm trying to compare.
(Apart from anything else, even just blindly adding the power figures for the 3C gun doesn't get me anywhere near 2.25, which is almost a relief because that feels like a meaningless thing to do in this case.)

Any tips?

* presumably this unit should be MJ/s or just MW

1614462308166.png

1614462541577.png

1614462548939.png
 
(In my head, "weapons capacitor draw" is synonymous with "distributor draw [from the WEP side]", but this may be wrong and might be at the root of the issue below.)

Correct, though maybe I should rephrase that for consistency.

The second and third pics show the detailed info for the top two weapons - the 4A and (first) 3C multicannons, including distributor draw and just plain "power draw".
What's confusing me is that the distributor draw for the (efficient) class 4 gun is around 0.2 MW, i.e. around 60% as much as the 0.34 MW distributor draw for the (overcharged) class 3 gun. But the EPS figures are around a factor of 3 apart, at 0.69 MW/s* and 2.25 MW/s.

The variable you're excluding is rate of fire. EPS is distributor draw per second, but "distributor draw" for non-beam weapons is per shot. The ROF of your engineered 4A is 3.367/s, while the 3C is 6.667/s. Multiplying those with the distributor draws yields the EPS as expected: 3.367 * 0.2035 = 0.685 ; 6.667 * 0.3375 = 2.250.

* presumably this unit should be MJ/s or just MW

Sure seems that way to me! I've mentioned that to FDev several times going back 3 or 4 years now or whenever I was first copying down module stats for edshipyard v0.1, but the game continues to use the nonsensical MW/s unit, so EDSY continues to follow suit. shrug
 
The variable you're excluding is rate of fire. EPS is distributor draw per second, but "distributor draw" for non-beam weapons is per shot. The ROF of your engineered 4A is 3.367/s, while the 3C is 6.667/s. Multiplying those with the distributor draws yields the EPS as expected: 3.367 * 0.2035 = 0.685 ; 6.667 * 0.3375 = 2.250.

Sure seems that way to me! I've mentioned that to FDev several times going back 3 or 4 years now or whenever I was first copying down module stats for edshipyard v0.1, but the game continues to use the nonsensical MW/s unit, so EDSY continues to follow suit. shrug
Well... O.M.G.
Thank you so much for clearing that up for me - it was really bugging me. It all makes sense now. I can plan my energy usage now, yay!

And it looks like the two bits I've quoted above are pretty closely related (!) - my brain just wasn't grasping the concept of MW * rate of fire (per second) still being MW. ROFL! Can't really imagine how they got that wrong in the first place, but maybe they have ignored your suggestion to fix it because they want to maintain consistency? (Hmm, that makes no sense though... Maybe just too much effort to fix.)

One other question you will know the answer to: a couple of years ago, before I paused playing for rather a long time, I asked about the effect of engine pips on agility (in this thread) and learned that the impact on some ships was negligible while on others if affected turn rates by well over a factor of 2 (pitch, roll and yaw).
Roll on 2021 and suddenly this isn't true any more. Only pitch is affected by pips, and even then the impact is dramatically reduced for all ships I've examined.
Coriolis still exhibits the old behaviour, but EDSY gets it right. I haven't found any thread which discusses this (pretty flipping enormous!) change - does one exist? I'd love to know when and why this change was made, and how on earth EDSY is getting it right when the Coriolis folks have been unaware? (Full marks though! :))
 
I don't remember the full history of this question, but it recently came up in discord. TLDR: pips actually do affect all three rotational speeds in theory, but only one ship (the T7) has its hull properties configured to make this happen in practice; all other hulls do indeed only lose pitch speed with low pips, and to varying degrees for each hull (reflected in the "min pitch speed" hull attribute).
 
I don't remember the full history of this question, but it recently came up in discord. TLDR: pips actually do affect all three rotational speeds in theory, but only one ship (the T7) has its hull properties configured to make this happen in practice; all other hulls do indeed only lose pitch speed with low pips, and to varying degrees for each hull (reflected in the "min pitch speed" hull attribute).
Thanks. I can't recall how carefully I tested any of the properties back in 2019, but I could have sworn that I was satisfied that (a) the pipSpeed entries in the Coriolis data were basically correct in terms of effect on pitch rate, and (b) that the pips truly did affect roll and maybe yaw too. I doubt that I did any testing in the T7 at the time, but for sure it was the appalling impact of reduced pips on agility in my AspX that made me investigate it all in the first place (and create the thread I linked above).
This all tends to imply that something significantly changed, but I can't be hugely confident. Did EDSY get any big changes in this respect since 2019?
In any case, it's good to know what the situation is now though :)
(Btw, looks like that Discord discussion is where felixlinker got the alert that Coriolis had a problem, and it was the resulting Github issue for Coriolis that first alerted me to the "new" behaviour, lol.)
 
I cannot find AX Multi-Cannons in EDSY, am I missing something?
---
Edit: Disregard. I just found them.
 
Last edited:
Any updates on the EDEngineer export? I'm in the process of building several ships and fully engineering some more so this would help a ton! Thanks!
 
Top Bottom