Release EDEngineer - an overlay to track your blueprint progress in realtime

It appears that the file that ED engineer is looking for in the Saved Games folder is no longer there.

I've tried all the troubleshooting steps on the Github page. The file that EDE is looking for is no longer in that directory.

When I open the link on the bottom right in EDE to the C:\Users\%USERNAME%\AppData\Local\EDEngineer it shows a blank file explorer screen that says "No items match your search."

If I just open file explorer and navigate to the folder, it's populated fully with the journal and json files.

Apparently the last ED update is no longer writing the file that EDE is looking for and therefore can't update any material counts.

Hope this can get fixed.

The Materials Monitor in EDDI is working and accurate, but is no replacement for EDE
 
Last edited:
Hey,

Is this issue similar to this one https://github.com/msarilar/EDEngineer/issues/525 ?

Is everybody affected by the problem or is that only for a few users? Whether you are affected or not, are you running Windows 10?

I can't launch the game for now and experiment myself unfortunately.
Yes - I'm on Windows 10

It could very well be a permissions issue as I can't see any files when I use the link from the EDE screen, but if I browse to the same directory, all the files are there.

I also can't get the program to run as Administrator from the Start Menu.

I edited the application permissions and will test again, but I'd rather just get the folder permissions properly edited for security reasons.

EDIT: No - still not reading.

Also, I am not a new user. I think it quit updating the correct amounts sometime in Nov/19 but I hadn't done much mats farming since then and just didn't notice it wasn't registering changes. So, I'm pretty much in agreement that this is a permissions issue that's preventing EDE from accessing the data folder, but looking at both the program and folder permissions, I can't identify what's wrong. Both EDE and the file folder are owned by my User account and have Full Control permissions and I am a member of the Administrators group.

The only possible issue that I can spot is that C:\Users\%Username%\Saved Games\Frontier Developments\Elite Dangerous folder is a Read Only folder. I wouldn't think that is a problem. ???
 
Last edited:
Hey,

Is this issue similar to this one https://github.com/msarilar/EDEngineer/issues/525 ?

Is everybody affected by the problem or is that only for a few users? Whether you are affected or not, are you running Windows 10?

I can't launch the game for now and experiment myself unfortunately.

I'm definitely not affected (Win 10), everything is working fine as always, besides the security warning on each update. But that was always the case for me.

But where I'm here, I've created a new commander recently which EDEngineer nicely separates by the commander choice line. On this way I noticed there's still a commander listed that I have given up (an ironman victim) and doesn't exist anymore. I'm curious now where EDEngineer is looking up the different commanders, I can't find him anywhere on my system. Somehow I feel I should know this, but I'm a bit sick currently, sorry...
 
Yes the folder being readonly is an issue.

Tech explanation for those who are curious:
EDEngineer monitors the file changes using a FileSystemWatcher but notifications don't get pick up by the Windows API for some reasons (I haven't really looked into it, always been like that ; I think it's because the handle never gets closed on the game's side which basically streams to file). To circumvent this, EDEngineer periodically "touches" the file to wake up the FileSystemWatcher in case a change happened. A readonly folder would keep the app from touching the files and thus no notification would ever be raised.
 
Regarding the ghost commanders : you either have remnant logs in your log folder that you could delete (or backup somewhere else) or you have manual changes for the commander in question (look up the github's wiki it should explain how that works and where to find the relevant files). Deleting these will make the ghost commander disappear from the app (commanders get generated by the app from logs being parsed).
 
Uh oh

No matter what I do windows won't let me get rid of the read only attribute on the folder.

I uncheck it and it just reverts to read only...

Researching

EDIT: The attribute on the folder is read only but all the files inside are not. EDE is still not updating the counts and when I click on the link from EDE it opens the file explorer to the correct directory, but no files are displayed and "No items match your search." is displayed. If I manually go to the same directory it's full of journal files. All the files are NOT read only. According to this MS article, that is normal. ???


Totally mystified. Also EDDI is correctly reading the counts for all materials. There also two journal.cache files and 6 .json files.

What are the search parameters EDE is using?

EDDI Materials.JPG EDE2.JPG Fileexplorer.JPG EDE2.JPG Cracked Industrial Firmware.JPG

Cracked Industrial Firmware is currently 198 - EDE is showing 183

Similar count problems with materials.
 
Last edited:
OK- I think I found the problem

I changed my Commander name a few months ago.

aggregation.json in the roaming directory and all the journal.log files also have the old cmdr name are still showing previous cmdr name.

How to fix???

I tried putting all files into a backup folder and then restarted EDE, but it only generated the aggregation.json file and it's using the previous cmdr name.

Confirmed: the last update in EDE is on 11/Nov/2019. I went through my old emails and Frontier confirmed the CMDR name change on Nov 12, 2019.

How to fix?

EDIT: Duh - SOLVED I didn't have "view commanders" expanded. Selecting the new CMDR name populated the correct numbers. Because I wasn't really running two different CMDRS I never gave a thought to having to switch names within the application. Nothing like overlooking the obvious...

All's well that ends well...

Odd that clicking the link to the data folder still doesn't populate the file list.
 
Last edited:
I've been using Inara until now for my shopping list, but fancied something a little more immediate so ive given this program a try.

I clicked on "Materials needed for this build" in Coriolis, and my CMDR name was there, so I clicked on send to EdEngineer. Whats interesting is a whole host of mats like Proto Radiolic Alloys for example just don't show up in EdEngineer, as they do in Inara, and as they do in Coriolis in the screen im using to send to Edengineer.

Maybe I'm missing something here - I am gathering the mats in a different ship to what I will be engineering, but that shouldn't make a difference if its getting the data from Coriolis?

EDIT: Looking thru the list it's only gotten 6 modules out of 11 from Coriolis I need to engineer.
 
Last edited:
I've been using Inara until now for my shopping list, but fancied something a little more immediate so ive given this program a try.

I clicked on "Materials needed for this build" in Coriolis, and my CMDR name was there, so I clicked on send to EdEngineer. Whats interesting is a whole host of mats like Proto Radiolic Alloys for example just don't show up in EdEngineer, as they do in Inara, and as they do in Coriolis in the screen im using to send to Edengineer.

Maybe I'm missing something here - I am gathering the mats in a different ship to what I will be engineering, but that shouldn't make a difference if its getting the data from Coriolis?

EDIT: Looking thru the list it's only gotten 6 modules out of 11 from Coriolis I need to engineer.

Clear all filters
 
OK - Is the proper Commander name selected?

EDIT: Also toggle the star on the left side to turn on/off "Show only for Favorites."

Bottom right - Is the proper directory being identified?
 
OK - Is the proper Commander name selected?

EDIT: Also toggle the star on the left side to turn on/off "Show only for Favorites."

Bottom right - Is the proper directory being identified?
Proper CMDR name selected, have turned off favourites (I havent created any favs so) and the correct directory is selected for the journals, and it says API on.

Heres a picture of my panel:

EDEng.jpg


EDIT: Looking at the full blueprints on Inara for the same build, I apparently require 24x Conductive Ceramics, 29x Proto Radiolic Alloys, 1x Pharmaceutical Isolators and 9x Datamined Wake Exceptions to complete the build.

According to EDEngineer its 1x Pharma, 9x Datamined Wake Exceptions and 5 Decoded Emission Datas if I'm reading the info correctly.

This is the build I exported to EDEng - https://s.orbis.zone/6ktm

And the mats Coriolis says I need for the build -

Carbon: 9
Shield Emitters: 6
High Density Composites: 3
Proprietary Composites: 10
Shielding Sensors: 10
Vanadium: 10
Compound Shielding: 10
Core Dynamics Composites: 10
Tungsten: 10
Specialised Legacy Firmware: 9
Mechanical Equipment: 3
Chromium: 6
Mechanical Components: 6
Configurable Components: 20
Modified Consumer Firmware: 10
Selenium: 20
Cadmium: 20
Cracked Industrial Firmware: 10
Pharmaceutical Isolators: 10
Atypical Disrupted Wake Echoes: 6
Chemical Processors: 6
Phosphorus: 42
Strange Wake Solutions: 3
Chemical Distillery: 10
Eccentric Hyperspace Trajectories: 10
Manganese: 80
Arsenic: 20
Chemical Manipulators: 10
Datamined Wake Exceptions: 10
Iron: 18
Irregular Emission Data: 6
Heat Exchangers: 3
Heat Vanes: 10
Germanium: 20
Unexpected Emission Data: 13
Proto Heat Radiators: 10
Niobium: 20
Decoded Emission Data: 20
Sulphur: 6
Conductive Components: 109
Anomalous Bulk Scan Data: 3
Electrochemical Arrays: 13
Unidentified Scan Archives: 10
Polymer Capacitors: 20
Classified Scan Databanks: 10
Military Supercapacitors: 10
Conductive Ceramics: 140
Conductive Polymers: 10
Improvised Components: 10
Salvaged Alloys: 60
Phase Alloys: 100
Proto Light Alloys: 200
Proto Radiolic Alloys: 100
Hybrid Capacitors: 6
Abnormal Compact Emissions Data: 10
 
Last edited:
Interesting

I don't see the Proto Radiolics either - what blueprint is using these in your build?
Collector Limpets & Prospector Limpets which I have 5x and 1x respectively. They are also using conductive ceramics which are also missing. I don't think when the blueprint is being imported it is taking into account multiples maybe?
 
Last edited:
A collector limpet requires 1 each of conductive ceramics, proto light alloys and proto radiolic alloys per roll at G5 (plus the latter for G4 rolls) which will need 9 or 10 rolls to complete per controller, x6 for all collector and prospector controllers.

Inara says I can roll 21 times at G5 hence the shortfall on Inara for 5 controllers and a Prospector that isnt been indicated by my Coriolis import to EdEngineer for some reason.
 
hello, I have a big problem with this application I install it and when I launch it nothing happens, it looks for updates 2 sec then nothing. it’s not even in the task manager,
I have searched the net but I have not been able to find a solution that works for me. (smartscreen disabled ...) please help me, ED without this application it is not possible.
 
c'est bon enfin mon problème a était résolu, pour ceux qui sont bloquer comme moi je vous dis comment j'ai fait:

j'ai désinstaller ED ingénieurs avec le logiciel Revo Uninstaller avec un scanne avancé pour être sûr.

j'ai mis a jours tout les pilotes ou presque d'abord avec Driver Booster 7 après avoir fini puis avec Driver Easy pour les pilotes rical citron.

j'ai installer ED engineer j'ai essayer sans succès ...

peut de temps après l'ordinateur me demande de déclencher pour se mettre un jour et après cela j'ai lancé ED ingénieurs miracle sa marche.
 
Top Bottom