Release ED ToolBox - A companion app

Just stumbled upon this great little app - can't believe I've not seen it yet!

Question, this is actually what led me here. I see it has a Bookmarks feature - is there any way to export that back into the game or import from the game? I tend to be the tour guide of my little group of friends and as such my in-game bookmark list is getting quite huge. I'd much rather use something that works in game as I play in VR and it's a pain in the to take off my headset to find something, type it in, get it wrong, headset off, etc. etc. First world problem, I know.

If ED Toolbox can't do this can anything?

~X
 
Hi Walter, just wanted to let you know that I did some debugging and found my "nearest station is in THIS system" fault.

Basically in this from SystemData.php ..

Code:
    if ($cs_distance == 0) {
        echo 'The nearest spaceport is in this system. ';
    } else {
        echo 'The nearest spaceport is in the ' . $cs_system . ' system, ' . $ambiguity . number_format($cs_distance, 1) . ' light years away.';
    }

.. it turned out that $cs_distance was something like 0.0000001234 so I changed the code as follows ..

Code:
    if (number_format($cs_distance, 1) == 0) {
        echo 'The nearest spaceport is in this system. ';
    } else {
        echo 'The nearest spaceport is in the ' . $cs_system . ' system, ' . $ambiguity . number_format($cs_distance, 1) . ' light years away.';
    }

Not very elegant but it fixed the problem! You might want to retro something similar (or better) back into your source tree.
Elegant schemelegant. If it works it works :)
 
Just stumbled upon this great little app - can't believe I've not seen it yet!

Question, this is actually what led me here. I see it has a Bookmarks feature - is there any way to export that back into the game or import from the game? I tend to be the tour guide of my little group of friends and as such my in-game bookmark list is getting quite huge. I'd much rather use something that works in game as I play in VR and it's a pain in the to take off my headset to find something, type it in, get it wrong, headset off, etc. etc. First world problem, I know.

If ED Toolbox can't do this can anything?

~X
Afaik you can't export/import the in-game bookmarks.
 
Hey Walter.

For the last few days I haven't been able to get any data for the current system, or even the name it for that matter:

EDTool_bug.png

Other data still comes through, like my ranks, ship cargo space, distance to other systems, etc. It seems to be just the current system data that doesn't show.

This has left me scratching my head as it was working up to a few days ago and I haven't changed anything. I double-checked that the log file path is still correct and that the appconfig.xml file has the VerboseLogging="1" line. Other than that I'm stumped, any suggestions?

Thanks
 
Hey Walter.

For the last few days I haven't been able to get any data for the current system, or even the name it for that matter:

View attachment 116859

Other data still comes through, like my ranks, ship cargo space, distance to other systems, etc. It seems to be just the current system data that doesn't show.

This has left me scratching my head as it was working up to a few days ago and I haven't changed anything. I double-checked that the log file path is still correct and that the appconfig.xml file has the VerboseLogging="1" line. Other than that I'm stumped, any suggestions?

Thanks
Have you checked the log directory that there are no extraneous files that could interfere? If you sort the files by date, the first file should be the latest ED log file.
 
Have you checked the log directory that there are no extraneous files that could interfere? If you sort the files by date, the first file should be the latest ED log file.
The latest file seems correct to me. It's called netlog.170321204218.01.log and it was created last night when I last used the game. So I'm not sure what the problem could be. Any other ideas?
 
The latest file seems correct to me. It's called netlog.170321204218.01.log and it was created last night when I last used the game. So I'm not sure what the problem could be. Any other ideas?
Can you open the file in a text editor and search for the system you last visited, or any system you visited the last time you played. If they're found in the log file then there's something else going on.
 
Can you open the file in a text editor and search for the system you last visited, or any system you visited the last time you played. If they're found in the log file then there's something else going on.
Sure, last night I was in Wyrd when I logged out. The system name appears in the log file:

Code:
System:"Wyrd" StarPos:(-11.625,31.531,-3.938)ly Body:1 RelPos:(-3.90811e+06,1.30355e+07,-8.0281e+06)km Supercruise
 
Last edited:
Sure, last night I was in Wyrd when I logged out. The system name appears in the log file:

Code:
System:"Wyrd" StarPos:(-11.625,31.531,-3.938)ly Body:1 RelPos:(-3.90811e+06,1.30355e+07,-8.0281e+06)km Supercruise
Is there anything in the EDTB\edtb_log.txt file?
 
Attaching the file...

View attachment edtb_log.txt

I can see a few types of errors, the 2 most common by far being:
Code:
[C:\Program Files (x86)\ED ToolBox\EDTB\style\Header.php on line 205] Error: Undefined variable: minm
[C:\Program Files (x86)\ED ToolBox\EDTB\action\updateAPIdata.php on line 78] Error: no output from API, see http://edtb.xyz/?q=common-issues#api_info for help
UPDATE:

Hey Walter. Turns out the issue was with Captain's Log having added some new files to the logs folder. The reason I didn't spot them at first is because, per my understanding of your instructions, all I was supposed to check for was these two things:
  1. That the latest file in the logs folder is a log file.
  2. That said log file contains the name of the last system I've been to.
But these files were a few rows down when sorting by date, so I didn't see them as they were buried under other log files. So it looks like you can get issues if there are any other files in the log folder that are not log files, not only if the latest file is not a log file.
 
Last edited:
Attaching the file...

View attachment 116939

I can see a few types of errors, the 2 most common by far being:
Code:
[C:\Program Files (x86)\ED ToolBox\EDTB\style\Header.php on line 205] Error: Undefined variable: minm
[C:\Program Files (x86)\ED ToolBox\EDTB\action\updateAPIdata.php on line 78] Error: no output from API, see http://edtb.xyz/?q=common-issues#api_info for help
UPDATE:

Hey Walter. Turns out the issue was with Captain's Log having added some new files to the logs folder. The reason I didn't spot them at first is because, per my understanding of your instructions, all I was supposed to check for was these two things:
  1. That the latest file in the logs folder is a log file.
  2. That said log file contains the name of the last system I've been to.
But these files were a few rows down when sorting by date, so I didn't see them as they were buried under other log files. So it looks like you can get issues if there are any other files in the log folder that are not log files, not only if the latest file is not a log file.
Hi,

Just noticed your edit. Thanks for debugging [up]
Does it work now?
 
ED Toolbox has started triggering the following popup (on initial opening of web page and then about every 5 minutes thereafter). Any thoughts?

 
When did this start?
Anyone else experiencing this?
Yesterday ... almost immediately after the big new Windows 10 update. It took me a while to figure out what was triggering it (the fact that it happened every 5-10 mins and stole focus from ED was the worst). I started killing things and when I stopped ED Toolbox it stopped. I'm about to play again in a while. I'll leave ED Toolbox off initially, then start it and see if the problem starts again.
 
Last edited:
Yesterday ... almost immediately after the big new Windows 10 update. It took me a while to figure out what was triggering it (the fact that it happened every 5-10 mins and stole focus from ED was the worst). I started killing things and when I stopped ED Toolbox it stopped. I'm about to play again in a while. I'll leave ED Toolbox off initially, then start it and see if the problem starts again.
Odd... Have you noticed if the errors coincide with any particular in-game events (mainly jumping from system to system or taking screenshots)? Or just randomly every 5-10 minutes?
 
Odd... Have you noticed if the errors coincide with any particular in-game events (mainly jumping from system to system or taking screenshots)? Or just randomly every 5-10 minutes?
Well it's still happening and definitely related to ED Toolbox. It happens when the Chrome web browser first opens on the toolbox page. It also seems to happen during a jump since the focus grabbing popup typically leaves me on the desktop just as my ship is hurtling towards the star.
 



Anybody else notice that the tool has become a resource hog lately? I have used this tool for a long time and it never used this much of my cpu before. And this is consistent. It stays at about 90%
 
http://i.imgur.com/OM89V4i.png


Anybody else notice that the tool has become a resource hog lately? I have used this tool for a long time and it never used this much of my cpu before. And this is consistent. It stays at about 90%
That's stupidly high. I've gotten reports of this happening when the amount of visited systems gets high. I'll check the database structure to check if there are some stupid mistakes there.

Is it like that all the time or only occasionally?
 
Well it's still happening and definitely related to ED Toolbox. It happens when the Chrome web browser first opens on the toolbox page. It also seems to happen during a jump since the focus grabbing popup typically leaves me on the desktop just as my ship is hurtling towards the star.
Ok, I'll investigate. In the mean time see if re-installing EDTB helps.
 
Top Bottom