Release ED ToolBox - A companion app

Hi everybody,

I'm trying to install the toolBox but when i click on the install .exe; nothing is happening... any idea?
Hi,

First, could you try to download the installer again (from a different mirror) and see if that helps any. If not, send me a private message so we can have a closer look at what's happening.
 
Your tool is simply AMAZING!
I'm using it since yesterday and I love it! Previously I was using EDDiscovery.

I've set up the EDSM key and everything else: can you confirm that the logs are now automatically sent to EDSM?
Or is there something I need to do?

Thanks
 
Thank you @ron2002 and @rizal72 for the kind words!

@rizal72: indeed if you've specified your api key and set the edsm_export variable to "true" then your position will be updated on EDSM in real-time. It doesn't work retrospectively so only your current position is sent to EDSM.
 
Thank you @ron2002 and @rizal72 for the kind words!

@rizal72: indeed if you've specified your api key and set the edsm_export variable to "true" then your position will be updated on EDSM in real-time. It doesn't work retrospectively so only your current position is sent to EDSM.
Thank you very much, and keep on with the good work!
 
Hi there. I'm doing development on my machine and port 3001 is already taken. How can I specify a different port?

EDIT: Ok, I've changed bin/apache/conf/httpd.conf to Listen 3333. How do I restart it?
EDIT2: Ok, restarted eliteapache and elitemysqld in Services. I don't have an ED Toolbox icon in my tray
EDIT3: Ok, started edtbmanager.exe, go the tray icon, crossing fingers...

EDIT4: The map isn't working give me this error in the chrome console:

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check http://xhr.spec.whatwg.org/.
VM318:3 Uncaught SyntaxError: Unexpected token )
 
Last edited:
Hi there. I'm doing development on my machine and port 3001 is already taken. How can I specify a different port?

EDIT: Ok, I've changed bin/apache/conf/httpd.conf to Listen 3333. How do I restart it?
EDIT2: Ok, restarted eliteapache and elitemysqld in Services. I don't have an ED Toolbox icon in my tray
EDIT3: Ok, started edtbmanager.exe, go the tray icon, crossing fingers...

EDIT4: The map isn't working give me this error in the chrome console:
I assume that's the Neighborhood Map? Can you download the following files from Github and replace the corresponding files to see if the error still occurs:
Code:
map.php
get/getMapPoints.js.php
get/getMapData.php
 
I assume that's the Neighborhood Map? Can you download the following files from Github and replace the corresponding files to see if the error still occurs:
Code:
map.php
get/getMapPoints.js.php
get/getMapData.php
Unfortunately not. Here's a screenie with more info. Yes, it's the Neihborhood Map, seems to fail because you use synchronous AJAX.

 
Unfortunately not. Here's a screenie with more info. Yes, it's the Neihborhood Map, seems to fail because you use synchronous AJAX.

http://content.screencast.com/users/Andargor/folders/Jing/media/d4484563-c549-4c6c-a3e1-c71784039abc/2016-01-19_1751.png
The JQuery warning is unrelated. Seems like this is another issue related to missing coordinates.
Couple of questions:
- Are you in a system with unknown coordinates?
- Have you updated the system and station data as instructed in the installer?
- Does ED ToolBox show your current location correctly?

Could you navigate to http://localhost:3001/get/getMapPoints.js.php and copy+paste the page to Pastebin or similar and pm me a link? Thanks.
 
The JQuery warning is unrelated. Seems like this is another issue related to missing coordinates.
Couple of questions:
- Are you in a system with unknown coordinates?
- Have you updated the system and station data as instructed in the installer?
- Does ED ToolBox show your current location correctly?

Could you navigate to http://localhost:3001/get/getMapPoints.js.php and copy+paste the page to Pastebin or similar and pm me a link? Thanks.
I was in Urvane, now in Shinrarta Dehzra, so known systems. I had followed the instructions, but I decided to re-run the update and pay more attention to the messages. There are errors on import, which is probably why it fails later on the map:

Downloading systems.zip...
Downloading stations.zip...
Downloading modules.zip...
Downloading commodities.zip...
Downloading rest.zip...
Unpacking archives...
Input Error: There is no script engine for file extension ".vbs".
Input Error: There is no script engine for file extension ".vbs".
Input Error: There is no script engine for file extension ".vbs".
Input Error: There is no script engine for file extension ".vbs".
Input Error: There is no script engine for file extension ".vbs".
Updating systems, this might take a while...
Error: could not locate C:/Users/<username>/AppData/Local/Temp/systems.csv
Updating stations, this might take a while...
Error: could not locate C:/Users/<username>/AppData/Local/Temp/stations.csv
Updating modules...
Error: could not locate C:/Users/<username>/AppData/Local/Temp/modules.csv
Updating commodities...
Error: could not locate C:/Users/<username>/AppData/Local/Temp/commodities.csv
Updating rest...
Error: could not locate C:/Users/<username>/AppData/Local/Temp/ships.csvError: could not locate C:/Users/<username>/AppData/Local/Temp/facilities.csvError: could no
t locate C:/Users/<username>/AppData/Local/Temp/musings.csvError: could not locate C:/Users/<username>/AppData/Local/Temp/powers.csvError: could not locate C:/Users
/<username>/AppData/Local/Temp/rares.csv
Updated

Removing temporary files...
Could Not Find C:\Users\<username>\AppData\Local\Temp\commodities.csv
Could Not Find C:\Users\<username>\AppData\Local\Temp\systems.csv
Could Not Find C:\Users\<username>\AppData\Local\Temp\stations.csv
Could Not Find C:\Users\<username>\AppData\Local\Temp\modules.csv
Could Not Find C:\Users\<username>\AppData\Local\Temp\ships.csv
Could Not Find C:\Users\<username>\AppData\Local\Temp\powers.csv
Could Not Find C:\Users\<username>\AppData\Local\Temp\musings.csv
Could Not Find C:\Users\<username>\AppData\Local\Temp\rares.csv
Could Not Find C:\Users\<username>\AppData\Local\Temp\facilities.csv

All done! Don't drink and fly!

You may now close this window
 
Last edited:
I was in Urvane, now in Shinrarta Dehzra, so known systems. I had followed the instructions, but I decided to re-run the update and pay more attention to the messages. There are errors on import, which is probably why it fails later on the map:
Well that would explain it. Seems like your OS has some other default application to open .vbs files (possibly notepad). I'll look into it and see if I can do something to this matter on my end, but in the mean time you can follow the instructions here: http://answers.microsoft.com/en-us/windows/forum/windows_xp-performance/error-there-is-no-script-engine-for-file-extension/ef023588-0c5c-4d37-a169-20eedb9c5a4c?db=5

This hopefully fixes the issue.
 
Installed this and I love it but I'd like to run it on my iPad or Android tablet but I am clueless how to start making this happen. They both sit on my desk and access the internet through the same router as my PC.

Can you give me a simple idiots guide as to how to make this happen?

Also I have voiceattack but am also clueless how to set urls as variables in it or where they go????

Sorry a tad lost, is there a stroke by stroke guide to doing these two things?

Totally excellent app though. :)
 

wolverine2710

Tutorial & Guide Writer
@Walter Harriman. Rep +1.

I've noticed that you have added your great mod to EDCodex - created by biobob and myself. Thanks a LOT for that. Your entry in it looks nice. Its near impossible to keep track of all new and exiting mods out there. I've missed your tbh ;-( So its great that commanders like you are adding/updating their mod entry there . The effort is very much appreciated ;-)
 
Last edited:
Installed this and I love it but I'd like to run it on my iPad or Android tablet but I am clueless how to start making this happen. They both sit on my desk and access the internet through the same router as my PC.

Can you give me a simple idiots guide as to how to make this happen?

Also I have voiceattack but am also clueless how to set urls as variables in it or where they go????

Sorry a tad lost, is there a stroke by stroke guide to doing these two things?

Totally excellent app though. :)
Unless you get a better answer before I get home, I'll get the details for both accessing on your tablet and using VA (I do both).

Basically, to access the DB from your tablet, just point its browser to the IP:port of your computer. Like: 192.168.1.120:3001

VA is a little tricky, but I'll have to wait until I get home.
 
Installed this and I love it but I'd like to run it on my iPad or Android tablet but I am clueless how to start making this happen. They both sit on my desk and access the internet through the same router as my PC.

Can you give me a simple idiots guide as to how to make this happen?

Also I have voiceattack but am also clueless how to set urls as variables in it or where they go????

Sorry a tad lost, is there a stroke by stroke guide to doing these two things?

Totally excellent app though. :)
ED ToolBox currently lacks proper documentation. I've written some short guides how to accomplish the things you mentioned:

Setting VoiceAttack variables
Accessing ED ToolBox from secondary devices

Hopefully these will help.

@AH_ImADot, thanks for offering to help! Any help in writing guides and just helping people on the forums is much appreciated.
 
@Walter Harriman. Rep +1.

I've noticed that you have added your great mod to EDCodex - created by biobob and myself. Thanks a LOT for that. Your entry in it looks nice. Its near impossible to keep track of all new and exiting mods out there. I've missed your tbh ;-( So its great that commanders like you are adding/updating their mod entry there . The effort is very much appreciated ;-)
Thanks :) The more apps the better IMO, gives people the choice.

I've been working on this thing for over a year but only recently decided to make it publicly available thanks to some encouragement from themroc ;)
 
Thanks everyone, I now have it on my iPad and my Android tablet. I'll work through doing the VA stuff but at first look it seems fully explained.

Looking forward to getting out into the Galaxy with this new tool.

Cheers again
 
Well that would explain it. Seems like your OS has some other default application to open .vbs files (possibly notepad). I'll look into it and see if I can do something to this matter on my end, but in the mean time you can follow the instructions here: http://answers.microsoft.com/en-us/windows/forum/windows_xp-performance/error-there-is-no-script-engine-for-file-extension/ef023588-0c5c-4d37-a169-20eedb9c5a4c?db=5

This hopefully fixes the issue.
Yep, that was it, thanks!
 
I've wholeheartedly suggested your AWESOME tool, in the UA and Barnacles official thread, being it one of the most visited thread ever and being the OP myself ;)
Among the various features, I think your VoiceAttack extension is simply AMAZING!
 
Last edited:
I've wholeheartedly suggested your AWESOME tool, in the UA and Barnacles official thread, being it one of the most visited thread ever and being the OP myself ;)
Among the various features, I think your VoiceAttack extension is simply AMAZING!
Thanks for the recommendation!
 
Top Bottom