Thank you both, @Aussiedroid and @Clicker

but what i dont get is:
why is on the main Page 5.0.0
9a47c01f37bd7c29758d9fb064808d14.png


and then on the release / download page only 4.3.0 readable?

b7cdb7a60460d50f30ab21ebdaafd55d.png


thats quite a bit confusing...
 
Yeah, GitHub can be a bit confusing like that. It is the way it manages different versions/branches.

Allows me to keep the latest stable version uploaded as a release version for Horizon players, and also share the beta version through the separate branch till I am happy with it.

You can select the branch, and also download the code from here:

1623464605139.png


As you see updates being uploaded (checking the latest dates column), you can re-download the zip to grab all the latest files again.

Hope it helps explain it further. :)

Cheers, AD
 
Yeah, GitHub can be a bit confusing like that. It is the way it manages different versions/branches.

Allows me to keep the latest stable version uploaded as a release version for Horizon players, and also share the beta version through the separate branch till I am happy with it.

You can select the branch, and also download the code from here:

View attachment 239288

As you see updates being uploaded (checking the latest dates column), you can re-download the zip to grab all the latest files again.

Hope it helps explain it further. :)

Cheers, AD
Awesome, great.. Thanx!
 
@Aussiedroid

Me again.

So I reset my windows install and did a full redownload of Odyssey, TARGET and all the other programs.

However now on starting any script (4.3 or 5.03) I get the same message as the script starts to initialise.

Error: (internal) cannot associate a filter with the selected USB HID device "VID_044F&PID_0404"
Error: (internal) cannot associate a filter with the selected USB HID device "VID_044F&PID_0402"
USB HID device with hardware id "VID_044F&PID_B687" cannot be found
Installing filter driver to VID_044F&PID_B679. Please Wait....Script stopped!
Done!
Error: (internal) cannot associate a filter with the selected USB HID device "VID_044F&PID_B679"

Runtime Error: STOP request received while running main on line 46 in "C:\Users\Imran\Desktop\AD-EDWarthogEnhancedScript-odyssey\Warthog Script\AD_ED_v5.0.0.tmc"
Error: Script run timed out!




All hardware is the same nothing is different from what it was 4+ hours ago when I started.

Any thoughts?
 
Hi @imski ,

That error indicates that TARGET cannot see your Joystick and Throttle, or, the drivers are not installed (or didn't fully install correctly)

PID_0404 = WARTHOG Throttle
PID_0402 = WARTHOG Joystick
PID_B687 = TWCSThrottle
PID_B679 = TFRP Rudder

You might also check or reseat the USB connections and try again.

Run joy.cpl and confirm the WARTHOG shows up there and let us know what you find please.

Lastly, What version of Windows are you running?
(run 'winver" and include the version shown)

Clicker
 
Hi @imski ,

That error indicates that TARGET cannot see your Joystick and Throttle, or, the drivers are not installed (or didn't fully install correctly)

PID_0404 = WARTHOG Throttle
PID_0402 = WARTHOG Joystick
PID_B687 = TWCSThrottle
PID_B679 = TFRP Rudder

You might also check or reseat the USB connections and try again.

Run joy.cpl and confirm the WARTHOG shows up there and let us know what you find please.

Lastly, What version of Windows are you running?
(run 'winver" and include the version shown)

Clicker
Windows 20H2 Build 19042,1052

Replugging the USB connectors worked but now I get

"

!! FATAL ERROR !!
EXITING Elite Dangerous .. Reason: Status.json file Not Found
Please set 'StatusFile' alias correctly in User Preferences
Refer to AD_EDUserPrefs.tmh file for instructions. Closing Down Script...
Script requested Abort!
Aborting script (check output above for reason)...
Script stopped!

Runtime Error: Script run aborted in main ( line 427 in AD_EDStatusJson_v5.0.0.tmh )"

However 4.3 works fine!
 
Last edited:
Hey @imski & @3KyNoX ,

When you get this error, have you set the correct path to the status.json file in the user preferences? If yes, does the script run for any period before it crashes or does it crash immediately?

With the latest build I have updated the json file reading to include the new on-foot flags based on CMDR Clicker's script so does vary compared to earlier version from a few weeks back. This added a bit of complexity to things too, but should still be able to read the file fine. If it is set and still causing issues though, I will look into it further.

Sorry to everyone too, I have been a bit slow on responses and updating the script further. Looking ahead at my real life schedule it might be a couple more weeks before I get some time to get back into it and test further.

Cheers, AD
 
FYI - status.json file is found in the same folder as the journal file and usually looks something like...

C:\Users\<your windows user name>\Saved Games\Frontier Developments\Elite Dangerous

Just change <your windows user name> in the path name above to suit.

Clicker
 
Top Bottom