Hey @Nick Bailey

Thanks for the feedback. I'll check it out my end next time I am in game. Can I confirm, is it just not working when on foot or does the system map not work at all in any modes?

In ship and on foot the switch doesn't bring up system map, srv i can't check at the moment.

Also i noticed now i can't jump with space .

Greetz Nick
4.3.0 works fine with Odyssey, the problem was, that I was stupid.
I only assigned the bindings to the "Ship Controls" but not in the other sub menus. So of course it won't work, if it's not bound.
After I assigned the binds in the other sub menus, everything works just as it should!

This script is such an astonishing work, getting so much out of the HOTAS is really incredible!
Hi Aussiedroid, Thank you for all your work on this (I have been using your script for a number of years now). I am trying to test v5 but get this error when attempting to run it: "Runtime Error: Symbol not found: A320Pilot in main ( line 33 in AD_ED_v5.0.0.tmc )". Does this mean anything to you?
Thanks again
Hey @Socautious - no worries at all :)

Thanks for checking out the new version. I'm a bit limited on play time so I haven't tested as much as I would like yet. Appreciate feedback.

The error you are seeing is likely due to you running an older version of Target software. Some new devices were added to the TM roster in 2020 which are now 'excluded' in the script (like the A320Pilot). Updating should resolve. Also worth checking your firmware versions while you are at it and ensure you are running the latest.

Good afternoon,
Does anyone know where fronter keeps their default binds?
It's hard to put into words want I am wanting to do. Basically, I just can't seem to get the control or accuracy needed to play the new 1st person pov of Odyessy.I would like to take the humanoid controller mappings and blend them into ADs custom binds. If I could use the Xbox controller when I exit the ship, that would be awesome.
I know I can choose the controller option from the On Foot Controls pulldown, but the HCS profile [in VA] notices that the bind selections are not the same and don't work correctly for me.
I have tried remapping the controls but I am unable to use the same buttons for more than one option, as the defaults do, that's what I want to make copies and look at them in an editor and see if I can make a demon love child between the two...
Hey Axsom,

Try this location: Elite Dangerous\Products\FORC-FDEV-DO-1000\ControlSchemes

Doing a search for .binds files found this location.

Strange you cannot remap directly though, but manually editing the binds file should work (have done that in the past myself to get around game limitations).

The only problem I have with binding through the game is that there are a couple of things the default has mapped to the same button, for instance, Crouch & Secondary Interact. I may change this later after I get playing it but for now, I want to duplicate the defaults... When I select the same button in-game it removes the first - as we all know. I do not know how to use the same map twice or if it can even be done, without doing it within the binds file.
I was able to get it to work - the only limit now is I have a wireless controller - which must be on when the game starts or the binds file errors because no 'pad' is found. I will solve this by replacing the wireless for wired when playing elite...
Hi Aussiedroid, Version 5.0.0 all working with no problems. Great job. Because I personally found turniing on-foot using the x-axis on the joystick very cumbersome, I bound rotate to the "rx-axis" (reducing sensitivity), pitch to the "ry-axis" and sprint to"joy 15". I quickly found this very comfortable. Although in combat I would return to mouse and keyboard.
Thanks again
Last edited:
I have done it...
Thank you, Aussie
By making a couple of simple changes I have merged controller control into your binds file.
quick question - why will Elite NOT see the binds file if I 'rename' it? I can make all the changes I want to it as long as I left the name alone. I have tried an N++ save as binds format, a rename in windows explorer, but it will not show in Elite unless I only do just a SAVE and leave the name alone - what am I overlooking?
@Axsom ,

You need to edit the profile description inside the file itself.
The game pays no attention to the actual file name.

Copy the actual .bind file and rename to whatever you like.
Then, using Notepad++, check the second to top line within the binds file itself.
This is what shows up in game when you select which profile to use.

Edit this to whatever you want, then in game, select this as your profile.

Hi Aussie i tried searching in the thread here and while some answers hint an answer for me i still am not sure how are the three firing modes on pinkie switch (left on throttle) actually work. i tried playing the fighter deployment training and tried to play with it a bit and ended up nearly not making it as the weapon was firing in weird patterns :D

I got everything the same you have it (but TPR pedals) (meaning i have hotas warthog with its throttle) all is set well the fw is updated the target script is updated, using the latest odyssey script with some personal preferences, i did not touch the firing mode preferences.

What happened is:
1. switch pinky to forward and then press mod1+primary fire that started shooting continuously. then tried to press mod1+fire and that should stop it from firing continuously?

2. switched pinky switch to down position did the same thing, then again mod1+fire primary and again tried to deactivate it with again pressing mod1+primary

this did not seem to work as the weapons since the first mod1+fire on pinky switch in down position it was shooting once in few seconds and i could not get it to stop no matter what i did (switch to middle and do the mod1+fire again.)

1. I think i just dont understand how this feature should work in your config, could you please describe the three firing modes on pinky switch and how to trigger them on and off properly, and when you actually use these in game (an example for each one) and how to mainly reset it to default firing (press trigger it fires)

2. looking at the advanced map im also a bit confused on how to trigger//hold mod3 and 4 and when to use these mod3 seems to be for pushtotalk but mod4? and what is mod4 used for? :D

Otherwise im pretty happy with it and yeah the on foot controls in latest need some tweaking for combat its kind of important to switch between the weapons while not turning off your shields (try the on foot tutorial).
first-time playing since last patch this week it seems I can no longer engage supercruise or hyperspace jump I'm having to alt-tab the game to engage the countdown
Oh its been busy over here! :)

@Socautious - Good to hear its working! I am definitely open to suggestions for the on-foot mappings. The ones I have now in the beta seem to work for me, but still feels somewhat off. Moving around the RX/RY and X/Y mappings may in worth a try, although I think most of the toggles will remain on one of the hat switches. Joy 15 for Sprint? Is that the button on the RX/RY hatswitch? If yes, I do want to give that a try.

@Axson - Nice one! Try Clicker's suggestion to resolve your naming issue - he's gotcha covered.

@nexy33 - Sounding like you may have a windows focus issue (ie something grabbing the focus from the ED client window)? I'll test this out my end next time I get to play. Do you have the SC on the throttle axis or on the china hat switch?

@Blecha100 - Hey, thanks for checking out the script. I'll double check the mappings for the weapons and shields, but I did think I had them separated on the HOTAS. Right direction was weapons and left for shields if I recall. With regards to the fire modes and how that all works, let me see if I can provide some more context. To point 1/2, yes that should be how it works (move pinky toggle fwd, pinky trigger and fire, then pinky and fire again to disable), just make sure that your pinky toggle is in the forward position when you disengage the fire mode. Same behaviour would be expected for the middle or bottom pinky toggle positions although the explorer mode will time out after the honk (so doesnt need to be disabled). Modifier 4's position should inform what type of fire mode to use with pinky trigger and fire. Could be something bugged out though, worth another try.

I mainly used the explorer mode myself, to help with the many honks out in the black. The pulsing mode can be good for mining to repeat the scanner pulse when looking for good roids. The combat mode can be good if you have an efficient weapon setup and would like to keep firing indefinitely on a target.

Modifier 3 is related to the Microphone controls. Default down position uses Elite's comms system in-game. This will mean the Mic on the throtte arm PTT is going to use the internal comms system. If toggle is in the up position then it will use external comms like Discord or Steam or whatever you may use. There are further configuration settings in the user preferences for the microphone too to customise to suit.

Let me know if you need anything else.

Hi Aussiedroid - I use rx/ry (I have the button upgrade from Delta Sim) to replace the mouse and the CMS on the Joystick for sprint, jump and crouch.
do we have an link for this newest version?

beccause here github i only see an old version from 2020

Hey @feiercrack, you are on the right branch and are looking at the latest version. Just "Download Zip" to grab all the files at once.

There will be no new "released" version for a while till its all tested properly. Odyssey still running terrible for me, even after a PC upgrade, and play time is limited so its slow going for right now.

Once its fully tested, the Odyssey branch will be merged with the main branch and a final release version will be created.

Cheers, AD
Top Bottom