Hi @Spud257,

The script actually checks for every compatible Thrustmaster device and shows what it found and what it didn't.
You can simply ignore those "cannot be found" messages.

Thrustmaster's Device Analyzer can be a bit hit and miss depending on which version of Windows you are running along with the firmware versions of the devices.

Which version of Windows are you running?
Have you tried checking the Joystick Control Panel?...
You should see this...


(I have T-Rudder and not the Crosswinds...the important info is the "Thrustmaster Combined"
Last edited:
My main problem is the joystick disappears, I have tried all the fixes online and in the forums and nothing works so i have surrendered and deleted target from my pc. thanks for trying to help.
When Target is not running, the joystick control panel shows both the Thrustmaster Joystick and Thrustmaster Throttle.

Assuming both of these are configured to be used within the script (which they are in Aussiedroids script), then, when the script runs, these are both replaced by Thrustmaster Combined device within the Joystick Control panel...this is normal.

If you ever change your mind and wish to use this script, we would be happy to assist.

Hi Clicker I finally got it to work, although not perfectly, I still have to unplug and replug the warthog joystick but thanks for your help, I am now trying to understand all that is ED gulp!
so.... I'm danish, and i got a danish keyboard. and i get this error: "Runtime Error: Symbol not found: KB_DA in main ( line 78 in AD_ED_v4.3.0.tmc )" ive tried, DNK DKK DA DAN DK nothing... same line same error, please assist a viking in need <3
Hi @Zastrow ,

Target script only recognises 3 different keyboard languages.

Unfortunately, Danish keyboard is not supported.

The only longshot solution would be to ask if someone has already built a custom defines.tmh and target.tmh to support Danish keyboard over on the HOTAS/HOSAS/SIMPIT discord ( in the Thrustmaster Community Q&A area)


Last edited:
well that sucks... can't i just change the OS kb layout to be UK and that would do it? i wont really use the KB while playing anyways?
Hi @Zastrow ,

Yes, you should be able to leave it as KB_ENG and see what works (and what breaks).
Whilst you may not be using the keyboard much directly, the script sends keyboard keystrokes.

The keys used are all defined within AD_EDKeyMap_v4.3.0.ttm file in Aussiedroids script bundle.
These all need to be included in the .bind file within the game options/controllers...so if you change anything, you need to change in both places.

Hope this helps
After hours testing it in combat the FA toggle is buggy. After several switches FA off-on the selection is inverted. Really anoying while in combat...
Hi @spivak

Whilst not ideal, pressing 'z' on your keyboard when selection is inverted will fix the problem.

In the meantime, if you are able to replicate the issue, please let us know any sequence which you find inverts the selection.
This will assist Aussiedroid to find a more permanent answer.

Hope this helps,

p.s. @Aussiedroid ... read status.json ... just saying!
Hi All,

It's been a while since I have logged into the forums!

Firstly, thanks CMDR Clicker for helping everyone out .. I see you have been busy over here! :)

I've been away from ED for a while awaiting the Odyssey release, but have prepped a beta across on GitHub to start updating it once we get our hand on it. Expect given the addition of first person mode there will be quite a lot to update. During the beta, I will not be releasing a new version but the latest beta builds will be available on GitHub directly. Obviously, these will be a WIP so may contain errors or issues but for early adopters you can give it a try. Feedback, issues etc during this phase are greatly appreciated, please report them on GitHub to ensure they are captured before public release. Likewise if you have any improvement suggestions or requests for the current build but have not raised them, now will be the time to ensure I can review before the next release.

@spivak - Thanks for reporting your issue. I doubled checked the code and cannot find any specific issues. I suspect if FAOff is being triggered quickly/frequently there may be something odd going on, maybe some ghosting or polling issues on the USB side resulting in the misalignment. Changing USB ports, disabling power management / suspend on the USB via Windows may assist, but will also add to my to-do list to see if I can add an override like I have done for some other toggles/buttons so it can be corrected in game using a modifier. Also would be good to know if you are using the hold or toggle action when you are seeing the issue.

@Clicker - Thanks for the reminder! I'll take another look into the status.json improvements. I noted you added some info here on the forums which makes a bit more sense than when we were chatting about it some time back. Back then it just wouldn't sink in and looked too complicated / too much work to retrofit but will revisit before I finalise my next public release :)

Much appreciated,

PS - Best place to get my attention these days is either on Steam via the guide or via GitHub, sorry to all of you sending me private messages here on the forums not getting a response for months!
Odyssey Beta Script Alert

I've been busy at work getting an updated version of the script ready for the Odyssey release. Lots of improvement & enhancements! Testing is going well, but given my limited time to play I appreciate any feedback from the community too if you are keen to get an early look at v5.0.0 release. Hoping to have this is a good place ready to add the new Odyssey bindings when the alpha drops so if you can, let me know your experience.

Files can be found here: https://github.com/Aussiedroid/AD-EDWarthogEnhancedScript/tree/odyssey

Check out the Changelog.txt for a list of the current changes.

A couple things to mention if you would like to try the beta script:

  • Please update to the latest v3.0.18.826 Target Software build.
  • Check User Prefs, there are some new ones, particularly you need to set a file path for status.json file else script will not run.
  • Things to try/test.. Many toggles have been rewritten, there are also many new messages output to the Target Window, both which need further validation. Many commands are now configured to only fire when in the right state so if you get commands not working let me know. Few new macros to try too. Any issues around status.json file reading or exceptions I am keen to know about too as this is a major feature of the new version.

Again, appreciate any/all feedback.

Thanks all, AD

I'll try to take a look at how you've incorporated the status.json stuff this weekend.
Noticed also...you've come to the dark side and are using layers ( MapKeyIOUMD() ) !

Just bought myself a Warthog but im lost in how to use this script. Can anyone give me some help in how i install and use it so i can play ED as im lost as it makes 0 sence to me. Im to old now lol
Hi @Ghastous ,

Thanks for checking out the script!

Happy to help out if I can. First point would be to follow the installation instructions in the guide to get the script and binding files to the right locations and cover a few other things to be aware of/set up. Can I ask if you have gone through these yet, or if you are getting stuck on any particular point? If you have any specific questions please let me know.

Cheers, AD
Top Bottom