Update 2.2.6 has been uploaded.

Official 'cleanup' release now 2.2 is out of beta.

List of Changes:

- Changed SRV digital steering to thumb hat on throttle. (more comfortable on extended sessions)
- Swapped Up/Down for Left/Right for Weapon Fire Group select. (prevents occasional triggering when exiting UI menus)
- Removed Fighter Focus and Replaced with new Fighter Orders mapping.
- Added Auto-Dock mappings for both short & long press when Pinky is held (previously just short press) .
- Removed variable name referencing Shadowplay (updated to Nvidia) since this is now integrated in the Geforce Experience 3.0 suite.
- Revalidated mappings post 2.2 official release.
 
Just noticed that Saitek has been sold to Logitech. I tried to warranty my mushy castle hat and was forwarded over to a generic Logitech forum until they come up with the replacement warranty claim site. If you are using a Saitek product and it messes up you are pretty much screwed.....What a mess and a sad way to treat a customer base.....
 
Just noticed that Saitek has been sold to Logitech. I tried to warranty my mushy castle hat and was forwarded over to a generic Logitech forum until they come up with the replacement warranty claim site. If you are using a Saitek product and it messes up you are pretty much screwed.....What a mess and a sad way to treat a customer base.....

Actually, Logitech is doing pretty well considering the mess they bought into. I had seen out a HOTAS for repair the day before the sale was announced. I figured I was screwed, but got an update request from Logitech, and things are moving forward.

Personally, I think this acquisition is good for both Saitek, and Logitech, and very glad it happened.

S1E
 
Excellent stuff Aussiedroid!

I'm going to try your solution right now as I've purchased the warthog one week ago and I'm still mapping buttons. Also half of the buttons of the throtle unit do not work or aren't detected by ED. Not to talk about yaw... which seems I've already managed a workaround. I was going to go deep into scripting when I found your post. Thanks a lot for your contribution in advance.
 
Excellent stuff Aussiedroid!

I'm going to try your solution right now as I've purchased the warthog one week ago and I'm still mapping buttons. Also half of the buttons of the throtle unit do not work or aren't detected by ED. Not to talk about yaw... which seems I've already managed a workaround. I was going to go deep into scripting when I found your post. Thanks a lot for your contribution in advance.

Many Thanks Madvic! Hope its all testing out okies!

You are a little limited by just mapping in ED, even though ED has excellent mapping options you can get the basics working, but that's not really making the most of your expensive device I guess :) Managing how the buttons/toggles/axes work outside of ED gives the most control, and script is certainly the most powerful (albeit hard to learn) option.
 
Many Thanks Madvic! Hope its all testing out okies!

You are a little limited by just mapping in ED, even though ED has excellent mapping options you can get the basics working, but that's not really making the most of your expensive device I guess :) Managing how the buttons/toggles/axes work outside of ED gives the most control, and script is certainly the most powerful (albeit hard to learn) option.

Very true. Yesterday the script ran ok and I loaded the profile. I like the mapping, and started testing. I think I'm missing something with the modifiers as I'm not being able to use some of the controls. Most important thing are the ship's panels (NAV, ROLE, SYSTEM and COMMS). I cannot open them using the right switch of the throtle (buttons 2-3-4-5-6), only with keyboard 1-4. The switch does nothing. I see in the map there is a (2) next to them, but I still haven't figured out the association. I'll try to test further today. Rest of buttons and functions work properly and behave as the map says as far as I've tested.

Anyway thanks to your work this is a huge advantage!
 
Great! Managed to figure it out! Excellent setup, let's play! [up][up]

Awesome, glad you figured it out!

Fly Safe CMDR

PS - I have also updated the guide on Steam to explain the Modifier buttons a bit more. Looking back on the guide it wasn't very obvious so I can understand why it might have caused some confusion. Cheers!
 
Last edited:
Good! I'm not very familiarized with this kind of complex button mappings on PC as I'm coming back from a long console period. Also with this joystick which adds difficulty. At the end I found that I had just to keep the modifiers buttons pressed. I played at finally yesterday for two hours with this setup and I have to say its easy to memorize, primary functions are very well mapped, and I started to control the ship and interfaces in a very natural way. And really looks like you're in control of everything with the enhanced functions, getting the most out of the device. I really enjoyed it a lot and know I can sleep in peace :)
 
Many thanks Aussiedroid for your work and sharing this.

I purchased the WartHog back in March, tried it out with the default profile, then went back to my old HOTAS, (X52Pro), as I could not stop playing Elite Dangerous long enough to learn a new HOTAS setup.

Now that 2.2.03 Beta is here for a few weeks or more, I figure this gives me the perfect opportunity to switch to the WartHog. I started on it earlier today, then came across this thread - exactly what I need to get going, (I also use TrackIR and MFG Crosswind Pedals).

Thanks again!
 
Last edited:
Merry Xmas!
Finally got to setup the software.

When using the throttle detents...the thing were you have to lift the throttle a bit...
Do I have to set up deadzones and/or correct the axis in the software? Or does the throttle recognise this and adjust the max/100%?

Thanks on advance!

Ok, ok...as always a RTFM helped here. The deadzone/throttle range has to be adjusted. :p
Maybe you still can post a screenshot. [wink]
 
Last edited:
Hey mr.Gr3y .. happy holidays!

I'm not sure if I am following. The deadzone if I am understanding, is set initially by the default settings in the script, then can be overridden by the 3 throttle presets depending on what you prefer. The lift/lock I think sits beyond this range (but I may be wrong).

Just on the topic of the lift/lock, I need to go back and look at a small issue, where it renders the throttle dead until it is used for the first time. Comment on my steam guide suggested it was the SRVHandbrake, so will see what I can do to address. Anyways, good to hear you got around to setting it up and having a play! :)
 
Loaded up your script and will now take some time to get into the details.

I started with "my own" and made a new one from the scratch but using the GUI. Next step will be the script editor.
 
Thanks again Aussiedroid for your online tutorial(s), posts, profiles, and especially the detailed Rem statements in your scripts. Also, many thanks to WraithMG11235, Alexander Zhevedenko, & DarkCyde0 as well.

Switching from the X52Pro with rotating Z-Axis to the WartHog & MFG Crosswind Pedals is not an easy feat; but after what seems like countless hours, I finally have a setup that I like. Perhaps not countless hours, more along the lines of two weeks, but that is still a long time not being able to jump in the cockpit and do some bounty hunting without having to think what to do with what hand, what finger, which foot, etc. I would post it, but it is still very much a WIP and not nearly as laidout or detailed as Aussiedroid's.

For what it is worth, if anyone else is making the plunge and switching to the Warthog; I recommend either adding, (double up), or replacing the 4 small springs on the rods under the pressure plate. This will help offset the tension on the main spring allowing for less resistance and yet still strong enough to smoothly snap back to the center position. After trying a couple different sizes and combinations, I ended up replacing the factory springs with:
5/16” x 1-1/2” x .020” (7.94mm x 38.10mm x 0.50mm) that I picked up from a local hardware store.

EDIT: just found this thread from Geoffrey.hdt using the exact same replacement springs. Great minds must think alike.
 
Last edited:
Good to hear from you Mister Tang! I was wondering how you were getting along :)

Happy to help, hope the comments were clear (I tried to explain most even though it makes the script a bit 'messy' at times). Its how I learned to figure out the scripting so thought it may be beneficial for others if they come across the profile and want to make changes (or like in your case to learn and create their own).

Would be great to see what you have created when/if you are ready to share. I am sure there will be things I can learn from you too! :) I had another inspired CMDR share their script with me a little while ago based on some of my script/others and I realised there is much I still do not know about this script coding stuff... and perhaps room for improvement in my own script at some point to incorporate some of their ideas.

I looked into the changing of springs myself, but decided I would give it some time first. I found I liked the strong spring in the end, but boy it took some getting used to (and needed a secure mounting). Thanks for sharing though, good info to have & will surely be helpful for others.
 
Hi Aussiedroid, following on from our conversation here, I have tried to run the script in the GUI, and although it runs without the loop issue, there are weird things going on. My desktop icons just keep flashing, and I am not able to run ED, so I have to stop the script.
Any ideas?
 
Hi Aussiedroid, following on from our conversation here, I have tried to run the script in the GUI, and although it runs without the loop issue, there are weird things going on. My desktop icons just keep flashing, and I am not able to run ED, so I have to stop the script.
Any ideas?

Hey imacken,

Hmm, are you running in Window Mode instead of Fullscreen by chance? Sounds like it doesn't have the full focus of the game and actioning things in Windows instead of ED. Would also try it when toggle switches are in default positions (off/down) when loading the script. Shouldn't matter but probably worth trying at least. Not sure what else it maybe at this stage.



Also just to share for everyone, if you are comfortable editing the script. The looping in Script Editor can be removed by commenting out (add a '//' before the line) or deleting the following:

Line 256/7 in ADEliteDangerous_v2.2.tmc:

"LockAxis(&Throttle, THR_RIGHT, 0);"));
// "ActKey(KEYON+UP+SRVHandbrake);"));

Also need to edit it out in ADEDMacros.tmh:

Line 289

// ActKey(KEYON+DOWN+SRVHandbrake);

and Line 296

// ActKey(KEYON+DOWN+SRVHandbrake);

Removes the SRV Handbrake on the Throttle Lock but I didn't use it really so hopefully wont be missed.
 
Update 2.2.7 : Maintenance Update

- Fixed the Throttle being dead/unresponsive when first using it in ED after running the script.
- Fixed Target Script Editor from looping on run of script when creating virtual device.
- Removed SRV Handbrake from Throttle lock as part of the above fix. Will need to rely the Joystick Trigger now.
- Improved the trigger timings of the On-Screen FPS & Bandwidth toggle switch on the Throttle. Will always trigger now!
- Removed Galaxy Map conflict with Comms/Chat Panel. Old mapping of / would prevent use of the slash commands when typing. eg. /r
(Please be aware, this will remove compatibility for Galaxy Map from VA.)

+ New! Fire Heatsink on Silent Running. Added a Joystick Trigger Modifier, which when held on toggling Silent Running will auto-fire a Heat Sink.
+ Add Flight Override mappings for lateral thrusters on the Joystick 'Target' Hat Switch (optional use). Allows thruster movements when wanting to toggle Landing Gear on takeoff.


New 2.2.7 pack should be available for download as soon as I clean a few things up. Thank you.

** Edit: For some reason I do not seem to be able to upload files currently. Please visit the ModDB link in the OP to get the latest version **
 
Last edited:
Thanks Aussiedroid, that has certainly solved all the looping/folder flashing issues I had. I'll try things out properly a bit later.
One thing I have noticed though - and it was the same in the previous version - is that I am not able to delete or move the temporary folder that I put your scripts in as a system error comes up saying that '.... the folder or a file in it is open in another program'.
Only a reboot of Windows will release it.
Don't know if it's a TARGET thing or your script.
 
Top Bottom